Полезная информация

Многие проблемы быстрее решаются поиском по форуму и чтением FAQ, чем созданием новой темы и томительным ожиданием ответа.

№2627-11-2016 20:19:07

Tronix
Участник
 
Группа: Members
Зарегистрирован: 04-02-2006
Сообщений: 383
UA: Seamonkey 2.9

Re: Почта Google сочла браузер SeaMoney "устаревшим"

yup
Благодарю.
Удивительно, но не помогло. Они, походу, скриптом определяют. Как-то можно обойти ?

Поменять Идентификатор сборки: Mozilla/5.0 (Windows NT 5.0; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1

Отредактировано Tronix (27-11-2016 20:20:10)

Отсутствует

 

№2728-11-2016 00:19:41

yup
Участник
 
Группа: Members
Зарегистрирован: 15-04-2016
Сообщений: 1086
UA: Seamonkey 2.40

Re: Почта Google сочла браузер SeaMoney "устаревшим"

Tronix пишет:

Удивительно, но не помогло. Они, походу, скриптом определяют. Как-то можно обойти ?

Вообще-то для разборок желательно иметь браузер, на котором проблема проявляется, но при беглом просмотре скриптов, используемых страничкой, кажется, что там таки строка User Agent анализируется.
Изучать ситуацию более детально у меня сейчас нет возможности.
Попробуйте вписать строку от моего [seamonkey] 2.40: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
И вообще, может имеет смысл обновиться?

UPD
Выкачал 2.9 Portable.
1. Выборочная подмена useragent в этой версии ещё не поддерживается. Есть только общая: general.useragent.override.
2. После подмены на строку от версии 2.40 Soundcloud начинает ругаться по-другому:

Sorry! Something went wrong
Is your network connection unstable or browser outdated?

Похоже, что ему, действительно, не хватает каких-то возможностей в браузере.

Отредактировано yup (28-11-2016 01:37:49)

Отсутствует

 

№2828-11-2016 15:43:20

Tronix
Участник
 
Группа: Members
Зарегистрирован: 04-02-2006
Сообщений: 383
UA: Seamonkey 2.9

Re: Почта Google сочла браузер SeaMoney "устаревшим"

Самое смешное, что еще месяц назад отключая сообщение о совместимости с  FF (в настройках) удавалось обойти проблему - то есть появлялась возможность зайти в профиль и слушать музыку . А в последние дни они  морочат голову "Is your network connection unstable or browser outdated?".

Я бы рад обновится - давным-давно, но у меня вин 2000 и выше [seamonkey] не ставится :(

Неужели в СМ нет файла, где эта инфа о версии стоит? Или всё в экзешнике прописано намертво? :(

Отредактировано Tronix (28-11-2016 15:48:31)

Отсутствует

 

№2929-11-2016 01:31:44

yup
Участник
 
Группа: Members
Зарегистрирован: 15-04-2016
Сообщений: 1086
UA: Seamonkey 2.40

Re: Почта Google сочла браузер SeaMoney "устаревшим"

Tronix пишет:

Самое смешное, что еще месяц назад отключая сообщение о совместимости с  FF (в настройках) удавалось обойти проблему - то есть появлялась возможность зайти в профиль и слушать музыку . А в последние дни они  морочат голову "Is your network connection unstable or browser outdated?".

Создатели сайтов имеют вредную привычку время от времени что-то в них переделывать. Похоже, что за прошедший месяц с Soundcloud стряслось именно это.

Tronix пишет:

Неужели в СМ нет файла, где эта инфа о версии стоит?

Раз после подмены useragent сообщение от сайта радикально меняется, значит, подмена подействовала, и сайт радостно попытался воспользоваться чем-то таким новеньким из браузера, чего у старого браузера не оказалось (useragent-то поддельный).
Разумеется, затратив некоторое время можно выяснить, и какая минимальная версия браузера устроит сайт, и что именно сайту нужно для нормальной работы - но легче-то от этого не станет: нет этого нужного в 2.9.
Можно даже такую аналогию привести: если, поковырявшись в Win2000 (5.0), суметь заставить её врать программам, что это WinXP (5.1), то от этого изменения Seamonkey 2.40 всё равно ведь в данной системе не заработает.

Отсутствует

 

№3030-11-2016 05:58:03

Tronix
Участник
 
Группа: Members
Зарегистрирован: 04-02-2006
Сообщений: 383
UA: Seamonkey 2.9

Re: Почта Google сочла браузер SeaMoney "устаревшим"

Ну, буду надеяться на лучшее...

Отредактировано Tronix (30-11-2016 06:31:20)

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]