В конце прошлой недели (числа 14 или 15 октября) открыл свой гугловский ящик на SeaMonkey (версия 2.40) и впервые увидел желтую полосу вот с таким объявлением:

Эта версия Firefox более не поддерживается. Установите поддерживаемый браузер.


Меня не волнует, что Гугл посчитал этот браузер "клоном" Firefox'a. Удивительно другое: почему Гугл решает за нас, каким браузером нам пользоваться? До сих пор SeaMonkey устраивал меня во всем. И ни у каких других сервисов, кроме гугловских, претензий к нему не было и нет.

Назойливое напоминание можно разово отключить. Но при новом обращении к ящику оно появляется снова. Вопрос такой: можно ли каким-то образом его отключить, и как это сделать? Ответ наверняка будет интересен не только мне, поскольку я — не единственный, кого почта Гугл донимает своей "инфой".

Zelenokot пишет:

почему Гугл решает за нас, каким браузером нам пользоваться?

А Google за вас и не решает, они перестраховуются от возможных судебных исков. Старые браузеры могут содержать уязвимости, которыми могут воспользоваться злоумышленники, а претензии потом могут быть выставлены Google. Вот они и перестраховались.

Zelenokot пишет:

можно ли каким-то образом его отключить, и как это сделать?

UAControl — расширение, которое позволяет вам контролировать, какой именно UA (User Agent) будет передаваться сайтам. Ставите его и конкретно для Google определяете UA более свежего браузера. Должно помочь.

Пожалуйста, подскажите, как именно я должен написать сайт Гугла и более свежую версию Мозиллы? Я попробовал указать Firefox 49.0 и в адресной строке поставил адрес входящей почты. Не помогло. Уведомление никуда не исчезло.

Предотвращая появление новых "остроумных" комментариев (вроде того, что ниже), поясняю: вопрос касался того, что я должен написать в настройках UA Control. Как грамотно прописать там версию Firefox'a, чтобы Гугл ее "проглотил".

Пожалуйста, подскажите, как именно я должен написать сайт Гугла и более свежую версию Мозиллы?

Процитируйте им первое сообщение. Если не отзовутся, то можно ещё в Спортлото написать.

Zelenokot, вот вам данные User Agent моего Firefox 50.0 b7:

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Указывать вот здесь (показано на примере этого форума):

скрытый текст
http://storage3.static.itmages.ru/i/16/1018/h_1476803314_7005881_fcd70cf426.png

http://storage7.static.itmages.ru/i/16/1018/h_1476803350_5292374_0cd72d2b29.png

black2024. спасибо Вам за хлопоты, однако расширение почему-то не работает ни на моей "лисе"-41, ни на SeaMonkey. Там оно попросту не ставится, поскольку этот браузер воспринимается очень устаревшей версией Firefox'a.

Предваряя технические вопросы: я скопировал строчку из Ваших данных. Адрес гугловского сайта ввел так: https://mail.google.com/mail/ Желтая полоса с уведомлением никуда не исчезла.

Есть ли альтернативные способы?

Для SM 2.40 можно и без расширений. В about:config создать строку: general.useragent.override.google.com
Значение: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

negodnik пишет:

Не знаю, почему Вы так себя назвали, но в моем случае Вы оказались волшебником! Сделал то, что Вы предложили, и... Гугл побежден!
Огромное Вам спасибо!

P. S. Если с SeaMonkey это прошло "на ура", то моя "лиса" 41-й версии, где тоже сидит гугловский ящик, почему-то остается с предупреждением. Может, и с нею что-то можно сделать? Ну, не хочется мне перескакивать на 49-ю версию. В нынешней у меня многое настроено под себя. В частности, прежний оконный вид настроек и выпадающий список поисковых систем.

Если в 41 уже поломали для отдельных сайтов, то сделайте сразу для всех: general.useragent.override

И еще раз Вам огромное спасибо! Моя "лиса" тоже избавилась от гугловской "жвачки"!

По поводу устаревших браузеров. У меня ОС ХР, [firefox] 42. Меняю юзерагент на [firefox] 49, Win 7 и всё равно пишет обновить,как будто видит через что-то ещё. Может кто знает.
http://34.ua/online/

скрытый текст
http://savepic.ru/11914730m.png

Присоединяюсь к вопросу от villa7.

villa7, manuk, может быть javascript или cookies?

Отслеживание параметров браузера и ОС пользователя как мера предотвращения угона аккаунтов

black2024
Почитал, но решения так и не нашёл.

Эта фраза про устаревший браузер содержится в скрипте http://i.ollcdn.net/current/player/xplayer.js
То есть, вам надо наших местных скриптописателей на помощь звать.
Но блокируют не по UA. В Fx47 создал параметр в config’е с юзерагентом Fx24 и ещё запустил скрипт на странице:
Object.defineProperty(window, "navigator.userAgent", {get: function() {return "Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0"}});
Уведомление дурацкое не появляется.
Может проще IPTV плейлисты где-нибудь нарыть, да послать подальше этот сайт.

negodnik
Это местный, городской канал, в подписках не встречал. Так у Вас заработал, или?

negodnik, послать подальше не проблема. Разобраться хочется. У меня на peers.tv такое: "Опаньки!
Для просмотра видео требуется браузер посвежее". XP SP3.

villa7, а я и не имел в виду, что по ссылке решение. По ссылке статья о том, как кроме UA можно определить браузер и ОС. вы ведь так озвучили:

и всё равно пишет обновить,как будто видит через что-то ещё. Может кто знает.

Вот я и высказал предположение, сославшись на статью, на основании чего могли определить.

У меня на peers.tv такое: "Опаньки!
Для просмотра видео требуется браузер посвежее". XP SP3.

Кодеков нету.

sentaus

sentaus пишет:

Кодеков нету.

Каких? В Хром подставляю тот же юзерагент всё работает, а в Лисе болт.

Каких?

Например, H264, используемых в HTML5. Они не поддерживаются FF в XP, по крайней мере из коробки.

sentaus, вы правы. После действий  https://habrahabr.ru/post/311626/ на FF 48 всё заработало. Жаль, что в FF 28 это не катит. Или катит?

negodnik пишет:

Для SM 2.40 можно и без расширений. В about:config создать строку: general.useragent.override.google.com
Значение: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

Благодарю за прекрасный совет! :)

Друзья, у меня  SeaMonkey 2.9.1
На https://soundcloud.com/spaceship-djtomeck (и на любой иной профиль-страницу https://soundcloud.com) не могу зайти, пишет Your current browser isn't compatible with SoundCloud.
Please download one of our supported browsers.
Совет В about:config создать строку: general.useragent.override.google.com
Значение: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 не помогает. Подскажите решение ситуации пожалуйста!

Tronix пишет:

Совет В about:config создать строку: general.useragent.override.google.com
Значение: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 не помогает.

Естественно, не помогает - эта строка настройки для google.com.
Для soundcloud.com она должна быть general.useragent.override.soundcloud.com

P.S. Seamonkey 2.40 этот сайт несовместимым не считает.

yup
Благодарю.
Удивительно, но не помогло. Они, походу, скриптом определяют. Как-то можно обойти ?

Поменять Идентификатор сборки: Mozilla/5.0 (Windows NT 5.0; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1

Tronix пишет:

Удивительно, но не помогло. Они, походу, скриптом определяют. Как-то можно обойти ?

Вообще-то для разборок желательно иметь браузер, на котором проблема проявляется, но при беглом просмотре скриптов, используемых страничкой, кажется, что там таки строка User Agent анализируется.
Изучать ситуацию более детально у меня сейчас нет возможности.
Попробуйте вписать строку от моего [seamonkey] 2.40: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
И вообще, может имеет смысл обновиться?

UPD
Выкачал 2.9 Portable.
1. Выборочная подмена useragent в этой версии ещё не поддерживается. Есть только общая: general.useragent.override.
2. После подмены на строку от версии 2.40 Soundcloud начинает ругаться по-другому:

Sorry! Something went wrong
Is your network connection unstable or browser outdated?

Похоже, что ему, действительно, не хватает каких-то возможностей в браузере.

Самое смешное, что еще месяц назад отключая сообщение о совместимости с  FF (в настройках) удавалось обойти проблему - то есть появлялась возможность зайти в профиль и слушать музыку . А в последние дни они  морочат голову "Is your network connection unstable or browser outdated?".

Я бы рад обновится - давным-давно, но у меня вин 2000 и выше [seamonkey] не ставится :(

Неужели в СМ нет файла, где эта инфа о версии стоит? Или всё в экзешнике прописано намертво? :(

Tronix пишет:

Самое смешное, что еще месяц назад отключая сообщение о совместимости с  FF (в настройках) удавалось обойти проблему - то есть появлялась возможность зайти в профиль и слушать музыку . А в последние дни они  морочат голову "Is your network connection unstable or browser outdated?".

Создатели сайтов имеют вредную привычку время от времени что-то в них переделывать. Похоже, что за прошедший месяц с Soundcloud стряслось именно это.

Tronix пишет:

Неужели в СМ нет файла, где эта инфа о версии стоит?

Раз после подмены useragent сообщение от сайта радикально меняется, значит, подмена подействовала, и сайт радостно попытался воспользоваться чем-то таким новеньким из браузера, чего у старого браузера не оказалось (useragent-то поддельный).
Разумеется, затратив некоторое время можно выяснить, и какая минимальная версия браузера устроит сайт, и что именно сайту нужно для нормальной работы - но легче-то от этого не станет: нет этого нужного в 2.9.
Можно даже такую аналогию привести: если, поковырявшись в Win2000 (5.0), суметь заставить её врать программам, что это WinXP (5.1), то от этого изменения Seamonkey 2.40 всё равно ведь в данной системе не заработает.

Ну, буду надеяться на лучшее...