Полезная информация

Будьте в курсе последних изменений в мире Mozilla, следя за нашим микроблогом в Twitter.

№125-08-2007 18:54:52

SSI
Участник
 
Группа: Members
Зарегистрирован: 25-08-2007
Сообщений: 6
UA: Firefox 2.0

Команда Thunderbird для отправки сообщений из командной строки

Как правильно прописать команду для запуска почтовой программы:
   1. В первом варианте нужна команда когда запустится программа, автоматически пропишется адрес КОМУ, адрес ОТ КОГО, вложиться указанный файл (несколько файлов), в сообщении пропишется текст из указанного файла.
   2. Во втором варианте выполнится отправка сообщения, при этом визуально программа открыватся не будет.
Это хочется использовать для использования прошраммы вместе с программой 1С- автоматическое уведомление клиентов и т.д. при определенных событиях. Прошу помощи.
:angel:

Отсутствует

 

№225-08-2007 20:28:02

St.MPA3b
Участник
 
Группа: Members
Откуда: Москва
Зарегистрирован: 23-05-2005
Сообщений: 1852
UA: Minefield 3.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Точно помочь не могу, т.к не пользуюсь этой прогамой, но попробуйте thunderbird --help :)


Я схожу с ума или это глючит Реальность?
Gentoo Linux (~x86) + Konqueror + Kmail ;). Не люблю GTK.

Отсутствует

 

№331-08-2007 17:23:36

SSI
Участник
 
Группа: Members
Зарегистрирован: 25-08-2007
Сообщений: 6
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Так и нет помощников. В Хелпе нет такой информации, а она нужна.

Отсутствует

 

№431-08-2007 17:41:49

unixman
Участник
 
Группа: Members
Зарегистрирован: 07-04-2007
Сообщений: 72
UA: unknown 0.0
Веб-сайт

Re: Команда Thunderbird для отправки сообщений из командной строки

Это невозможно! Нужен специальный текстовый email-клиент! А когда вы его будете настраивать, вы поймете, что это не для вас!


Юникс, Линукс, Mac OS X! Все против Хриндоус XP и Хриндоус Виста!

Как и  linux'оиды, я тоже в кедах потому что пользуюсь BSD (Mac OS X) , а BSD создана на основе Unix'а , а Linux тоже создан на основе Unix'а

Отсутствует

 

№531-08-2007 17:46:42

SSI
Участник
 
Группа: Members
Зарегистрирован: 25-08-2007
Сообщений: 6
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

C этого момента поподробней. Сам программирую 1С, но по простому для своей компании, а вот этого я еще не знаю.

Добавлено Птн 31 Авг 2007 17:54:36 :
Вот это я зная:

"c:\program files\mozilla thunderbird\thunderbird.exe" -compose "to=test@mail.ru,subject=test,attachment='file:///d:/test/test.txt'"

но здесь нет команды для текста сообщения.
Помогите

Отсутствует

 

№631-08-2007 22:51:43

St.MPA3b
Участник
 
Группа: Members
Откуда: Москва
Зарегистрирован: 23-05-2005
Сообщений: 1852
UA: Minefield 3.0

Re: Команда Thunderbird для отправки сообщений из командной строки

SSI
Поставь аналог sendmail для винды... если есть.


Я схожу с ума или это глючит Реальность?
Gentoo Linux (~x86) + Konqueror + Kmail ;). Не люблю GTK.

Отсутствует

 

№702-09-2007 16:18:09

Unghost
Призрак-админ
 
Группа: Administrators
Откуда: Moscow, Russia
Зарегистрирован: 08-10-2004
Сообщений: 11771
UA: Minefield 3.0

Re: Команда Thunderbird для отправки сообщений из командной строки

есть blat


Do not meddle in the affairs of Wizards, for they are subtle and quick to anger.

Отсутствует

 

№819-09-2007 13:58:40

Kossstya
Участник
 
Группа: Members
Зарегистрирован: 19-09-2007
Сообщений: 3
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

В 1с есть возможность отправки сообщений автоматически, не клацая на кнопочку отправить. НО ТОЛЬКО С ПРОТОКОЛОМ SMTP. Вот такой код:
Попытка
    ОтправитьПоПочте2(ТекСтрока); // работает с Батом
Исключение
    Попытка
    ОтправитьПоПочте1(ТекСтрока); // работает с Аутлуком, но переспрашивает при отправке
    Исключение
        Сообщить_и_записать("Ошибка при отправке почты - "+ОписаниеОшибки(),СтатусСообщения.Важное);
    КонецПопытки;
КонецПопытки;

Процедура ОтправитьПоПочте1(ТекСтрока)
    Почта = Новый Почта;
    Сообщение = Новый ПочтовоеСообщение;
    //Работает с Аутглуком, но переспрашивает приотправке
    //не работает с Батом 3.60
    Почта.Подключиться("name@mysite.dp.ua","password");
   
    Сообщение.Вложения.Добавить(ПолучитьИмяФайлаПодразделения(ТекСтрока.филиал.наименование));
    Сообщение.Получатели.Добавить(ТекСтрока.филиал.email);
    Сообщение.Тема ="Проигнорированные документы в офисе. Письмо сгенерированно роботом";
    Сообщение.Текст="Проверьте, будь ласка эти документы ПОСЛЕ получения обновления из офиса. Ваши изменения в этих документах не попали в базу. Откройте прикрепленный файл";
    Почта.Послать(Сообщение);
    Почта.Отключиться();
    УдалитьФайлы(ПолучитьИмяФайлаПодразделения(ТекСтрока.филиал.наименование));
КонецПроцедуры           

Процедура ОтправитьПоПочте2(ТекСтрока)
    ПочтовыйПрофиль = Новый ИнтернетПочтовыйПрофиль;
    ПочтовыйПрофиль.АдресСервераPOP3   = "pop3.mysite.dp.ua";
    ПочтовыйПрофиль.АдресСервераSMTP   = "smtp.mysite.dp.ua";
    ПочтовыйПрофиль.ПортSMTP           = 25;
    ПочтовыйПрофиль.ПортPOP3           = 110;
    ПочтовыйПрофиль.Пользователь       = "name";
    ПочтовыйПрофиль.Пароль             = "password";
    ПочтовыйПрофиль.ВремяОжидания      = 60;
       
    Сообщение = Новый ИнтернетПочтовоеСообщение ;
    Сообщение.Вложения.Добавить(ПолучитьИмяФайлаПодразделения(ТекСтрока.филиал.наименование));
    Сообщение.Получатели.Добавить(ТекСтрока.филиал.email);
    Сообщение.Тема ="Проигнорированные документы в офисе. Письмо сгенерированно роботом";
    Сообщение.ИмяОтправителя="Обмен";
    Сообщение.Отправитель="name@mysite.dp.ua";
       
    Текст = Сообщение.Тексты.Добавить("Проверьте, будь ласка эти документы ПОСЛЕ получения обновления из офиса. Ваши изменения в этих документах не попали в базу. Откройте прикрепленный файл");
    Текст.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
   
    Почта = Новый ИнтернетПочта();
    Почта.Подключиться(ПочтовыйПрофиль);
    Почта.Послать(Сообщение);
    Почта.Отключиться();
    УдалитьФайлы(ПолучитьИмяФайлаПодразделения(ТекСтрока.филиал.наименование));
КонецПроцедуры       
ВСЕ БЫ ХОРОШО, НО У МЕНЯ НЕ ПОЛУЧИЛОСЬ ЗАСТАВИТЬ 1с РАБОТАТЬ С IMAP-м (хотя, может, я просто не докопал в правильном направлении - я не ставил бат :) Но у нас Бат не работает по IMAP... ).
Вот так 1с работает с Мозилой Сундербердом:
ПутьМозиллы = """C:/Program Files/Mozilla Thunderbird/thunderbird.exe""";
    Текст = Новый ЗаписьТекста(КаталогОбмена + "sendfiletofilial"+Строка(ТекСтрока.филиал.наименование)+".bat", КодировкаТекста.OEM);
    Текст.ЗаписатьСтроку("@echo off");
    Текст.ЗаписатьСтроку("@echo Отправка проигнорированных писем на филиал"+Строка(ТекСтрока.филиал.наименование));
    СтрокаЗапуска = " -compose to='"+ТекСтрока.филиал.email+"',cc='name@mysite.dp.ua',subject=""Проигнорированные документы в офисе. Письмо сгенерированно роботом"",body=""Проигнорированные документы в офисе. Письмо сгенерированно роботом"",attachment=""file://";
    Файл = """"+ПолучитьИмяФайлаПодразделения(ТекСтрока.филиал.наименование)+"""";
    Текст.ЗаписатьСтроку(ПутьМозиллы+СтрокаЗапуска +Файл);
    Текст.ЗаписатьСтроку("del "+Файл);
    Текст.Закрыть();
    ЗапуститьПриложение(КаталогОбмена + "sendfiletofilial"+Строка(ТекСтрока.филиал.наименование)+".bat",КаталогОбмена)

Отредактировано Kossstya (19-09-2007 14:04:26)

Отсутствует

 

№919-09-2007 14:11:25

SSI
Участник
 
Группа: Members
Зарегистрирован: 25-08-2007
Сообщений: 6
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Спасибо за поддержку. Что-то на вроде этого я уже смастерил, но код любопытный.
А как теперь вставить в тело сообщения табличный документ. Т.е документ сформированный в 1с на печать (пусть это будет счет на оплату) вставить в тело сообщения..........

Отсутствует

 

№1019-09-2007 15:39:19

Kossstya
Участник
 
Группа: Members
Зарегистрирован: 19-09-2007
Сообщений: 3
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Тебе можно не загонять данные в текст письма, а сделать по типу такое:
Для каждого СтрокаТаблицы Из ТаблицаОтчетов Цикл
    ИмяТемпФайла = ПолучитьИмяВременногоФайла();
    СтрокаТаблицы.Отчет.Записать(ИмяТемпФайла,
    ТипФайлаТабличногоДокумента.HTML);
КонецЦикла
См. хелп по ПолучитьИмяВременногоФайла(), а потом созданный файл присоединяешь к письму и х..чишь его покупателю по почте. Если так не подойдет, то создавай объект Word или Excell и затем шли по почте

Отсутствует

 

№1119-09-2007 15:49:19

SSI
Участник
 
Группа: Members
Зарегистрирован: 25-08-2007
Сообщений: 6
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Хорошо получается, когда
Адрес=АдресЭлПочты;
   
    СтруктураНовогоПисьма = Новый Структура;
        Если НЕ ПустаяСтрока(Адрес) Тогда
            СписокКому = Новый СписокЗначений;
            СписокКому.Добавить(Адрес, Значение.Наименование);
            СтруктураНовогоПисьма.Вставить("Кому", СписокКому);
    КонецЕсли;
        СтруктураНовогоПисьма.Вставить("Тема",ТемаСообщения);
        СтруктураНовогоПисьма.Вставить("Тело",Текст.ПолучитьТекст());
               
        #Если Клиент Тогда
        НаписатьПисьмо(глТекущийПользователь, СтруктураНовогоПисьма,,,);
        #КонецЕсли
а Текст- это Текст=Новый ТекстовыйДокумент ();, где есть все строки.
Так вот ВОПРОС- как в виде ТЕКСТА получить то, что идет на печать???? в 1с, а далее видишь сам, что все просто.

Отсутствует

 

№1219-09-2007 17:43:31

Kossstya
Участник
 
Группа: Members
Зарегистрирован: 19-09-2007
Сообщений: 3
UA: Firefox 2.0

Re: Команда Thunderbird для отправки сообщений из командной строки

ты в любом случае выводишь на печать ТабличныйДокумент. В нем нет функции сохранения в файл. Тебе нужно сделать ТекстовыйДокумент и выводить в него все то, что ты выводишь в табличный документ

Отсутствует

 

№1305-05-2011 23:03:36

ma8883
Участник
 
Группа: Members
Зарегистрирован: 16-05-2010
Сообщений: 14
UA: Opera 11.1

Re: Команда Thunderbird для отправки сообщений из командной строки

Ребят, почти 4 года прошло. Появился выход из данной ситуации?
Запуска птицу из командной строки, она хватает нужный файл, и остается нажать кнопку "Отправить" для полного счастья, как эту операцию прописать в батник?
"C:\temp\Thunderbird 2011\ThunderbirdPortable.exe" -compose to=mypochta@ya.ru,subject='tema',attachment='C:\ma8883\support.txt'

Или подскажите подобный небольшой клиент, именно портабл версию, и почтовик который умеет работать через прокси (есть в меню место куда забить адрес, логин и пароль для авторизации), ну и поддержка командной строки.

Очень жду советов!

Отсутствует

 

№1406-05-2011 13:46:05

luitzen
Участник
 
Группа: Members
Зарегистрирован: 19-07-2008
Сообщений: 791
UA: Nightly 6.0

Re: Команда Thunderbird для отправки сообщений из командной строки

ma8883 пишет

Ребят, почти 4 года прошло. Появился выход из данной ситуации?

Можно сказать окну составления сообщения, чтобы при определённых условиях оно, будучи вызванным, само отправляло письмо и закрывалось.
Поищите в форуме по словам "cmd_sendButton".

Отсутствует

 

№1528-03-2015 14:08:26

Strek
Забанен
 
Группа: Members
Откуда: Украина-->Чернигов
Зарегистрирован: 28-03-2012
Сообщений: 73
UA: Firefox 36.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Отсутствует

 

№1628-03-2015 17:15:56

Dzirt
Участник
 
Группа: Members
Зарегистрирован: 26-02-2012
Сообщений: 1891
UA: Firefox 35.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Strek, вы думаете, что через 4-е года после последнего сообщения ссылка на описание параметров командной строки TB, которая к тому же не отвечает на поставленный в теме почти восемь (!) лет назад вопрос, еще кого-то интересует? ;)

Отсутствует

 

№1729-03-2015 01:26:50

firespace
 
 
Группа: Extensions
Зарегистрирован: 26-01-2011
Сообщений: 609
UA: Firefox 39.0

Re: Команда Thunderbird для отправки сообщений из командной строки

Dzirt
Вспомнился боян про блондинку в шкафу. :)

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2020 Mozilla Russia GitHub mark
Язык отображения форума: [Русский] [English]