Полезная информация

Общайтесь со знакомыми и друзьями в нашей группе в Контакте.

№85129-11-2010 00:41:38

Lain_13
Забанен
 
Группа: Members
Откуда: Волшебная Страна
Зарегистрирован: 26-04-2006
Сообщений: 10320
UA: Firefox 4.0

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

krigstask
> Ну там-то элементарно выставляется.
Да видишь ли, не люблю я лазить в потроха иксов голыми руками. Очень не люблю.

Отсутствует

 

№85229-11-2010 00:42:56

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

MySh пишет

Это с правами обычного пользователя, или от root тоже? Сталкивался с тем, что из-под простого пользователя каталог с примонтированной дискетой не хотел читаться ни в какую.

От root тоже.

Отсутствует

 

№85329-11-2010 00:43:25

MySh
Кактусогрыз
 
Группа: Extensions
Зарегистрирован: 17-12-2006
Сообщений: 4623
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Радик245

Что это значит — установилось или нет?

Это после какой команды?

Отсутствует

 

№85429-11-2010 01:16:24

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

MySh
После второй.

Отсутствует

 

№85529-11-2010 08:53:08

krigstask
друг народа
 
Группа: Members
Откуда: Rampova, Inkerimaa
Зарегистрирован: 13-09-2005
Сообщений: 4593
UA: Opera 10.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Lain_13 пишет

Да видишь ли, не люблю я лазить в потроха иксов голыми руками. Очень не люблю.

Ну что тут скажешь, вольному воля (-:Е


Ядрёная консоль делает меня сильней!

Отсутствует

 

№85629-11-2010 17:53:08

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Chrome 7.0
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

MySh пишет

Можно добавить репозиторий и не через консоль. Там же, на странице, ниже информации с кодом репозитория, есть зелёная такая ссылочка с текстом «Technical details about this PPA». Если по ней щёлкнуть, она развернётся и можно будет увидеть текст, в котором будут такие строки в рамочке:

deb http://ppa.launchpad.net/intgr/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/intgr/ppa/ubuntu lucid main

Их можно добавить в Synaptic: «Настройки → Репозитории → Другое ПО → Добавить…». После этого нужно будет «Обновить список» — и пакеты из этого репозитория должны появиться в списке.

Через Synaptic можно и add-apt-repository ppa:intgr/ppa.

Добавлено 29-11-2010 17:53:41
И лучше заморочиться с репозиторием, чтобы ошибок как выше не вылезало.

Отредактировано igorsub (29-11-2010 23:19:29)


От оно че!

Отсутствует

 

№85729-11-2010 22:29:14

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

MySh пишет

Можно добавить репозиторий и не через консоль. Там же, на странице, ниже информации с кодом репозитория, есть зелёная такая ссылочка с текстом «Technical details about this PPA». Если по ней щёлкнуть, она развернётся и можно будет увидеть текст, в котором будут такие строки в рамочке:

deb http://ppa.launchpad.net/intgr/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/intgr/ppa/ubuntu lucid main

Их можно добавить в Synaptic: «Настройки → Репозитории → Другое ПО → Добавить…». После этого нужно будет «Обновить список» — и пакеты из этого репозитория должны появиться в списке.

Те же ошибки, что и в терминале.

igorsub пишет

лучше заморочиться с репозиторием

Это как?

Отредактировано Радик245 (29-11-2010 22:31:04)

Отсутствует

 

№85829-11-2010 23:19:05

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Firefox 3.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Радик245 пишет

Это как?

Это как было описано выше.

Добавлено 29-11-2010 23:20:58
И в том репозитории все-таки для lucid пакет.

Добавлено 29-11-2010 23:28:01
И udisks 1.0.1 - это последняя версия. Ее можно из официального репозитория Маверика взять, но она, как ты говоришь, тебе не подходит.


От оно че!

Отсутствует

 

№85929-11-2010 23:28:10

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Пакеты, конвертированные alien, установились (хотя при конвертации cnijfilter-ip3600series выскочило предупреждение:

Warning: Skipping conversion of scripts in package cnijfilter-ip3600series: postinst postrm
Warning: Use the --scripts parameter to include the scripts.

), но принтер не заработал — мигает жёлтая лампочка, как при установке «чужого» драйвера. Я удалил cnijfilter-ip3600series, конвертированнный из rpm, и попытался установить неконвертированный deb. И тут заметил заголовок: «К сожалению, «cnijfilter-ip3600series» недоступен для вашего типа компьютера (i386)». Естественно, попытка установки завершилась ошибкой.
Существует ли способ конвертировать пакет для i386?

Отредактировано Радик245 (29-11-2010 23:29:09)

Отсутствует

 

№86029-11-2010 23:34:46

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Firefox 3.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

А Canon мог не встать из-за того, что что пакет написан под Debian, а у него все же есть своя небольшая специфика. Это не 100% Ubuntu. Вот тут есть небольшая инструкция по установке твоей модели.


От оно че!

Отсутствует

 

№86129-11-2010 23:35:58

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

скрытый текст

igorsub пишет

Это как было описано выше.

igorsub пишет

PPA - это репозитории на launchpad.net. Чтобы их установить, нужно зайти на страницу какого-либо проекта или автора, который занимается сборкой того или иного пакета, узнать данные по репозиторию и ввести в консоли следующее:

Выделить код

Код:

sudo add-apt-repository ppa:данные/репозитория

Например, sudo add-apt-repository ppa:webkit-team/ppa.

Затем просто sudo apt-get update && sudo apt-get upgrade.

MySh пишет

То есть в данном случае команда будет такая:

sudo add-apt-repository ppa:intgr/ppa

После, как выше написал igorsub, нужно будет в консоли набрать ещё одну команду:

sudo apt-get update && sudo apt-get upgrade

Терминал пишет

Получено 2 638Б за 3с (743Б/c)                                   
W: Не удалось получить http://ppa.launchpad.net/intgr/ppa/ubuntu/dists/maverick/main/source/Sources.gz  404  Not Found

W: Не удалось получить http://ppa.launchpad.net/intgr/ppa/ubuntu/dists/maverick/main/binary-i386/Packages.gz  404  Not Found

E: Некоторые индексные файлы не скачались, они были проигнорированы или вместо них были использованы старые версии


Чем одно лучше другого — не понял.

Отредактировано Радик245 (29-11-2010 23:55:41)

Отсутствует

 

№86229-11-2010 23:37:55

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Firefox 3.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Радик245
Я к тому, что пакеты лучше не устанавливать вручную, как советовал MySh, если еще не достаточно опытен в линуксах.


От оно че!

Отсутствует

 

№86329-11-2010 23:47:15

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub
Спасибо, но только там пишут про установку на AMD64… и на английском. Я правильно понял, что сначала надо распаковать .tar.gz в /usr/local/lib/ip3600_driver, а затем установить пакеты deb командой sudo dpkg -i --force-architecture cnijfilter-common_3.00-1_i386.deb cnijfilter-ip3600series_3.00-1_i386.deb ?

Отредактировано Радик245 (29-11-2010 23:50:30)

Отсутствует

 

№86430-11-2010 00:49:52

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Терминал пишет

dpkg: зависимости пакетов не позволяют настроить пакет cnijfilter-common:
cnijfilter-common зависит от libcupsys2 (>= 1.2.1), однако:
  Пакет libcupsys2 не установлен.

В то время как последняя версия этого пакета установлена. Что ещё можно предпринять?
Читал и инструкцию по установке, которая с сайта Canon — результат тот же.

Отредактировано Радик245 (30-11-2010 01:25:37)

Отсутствует

 

№86530-11-2010 17:35:46

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Firefox 3.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Радик245 пишет

Спасибо, но только там пишут про установку на AMD64

Но устанавливается драйвер для архитектуры x86.


От оно че!

Отсутствует

 

№86630-11-2010 17:54:45

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub
Ну я уже написал, к чему приводит попытка установки. Ещё идеи есть?

Отсутствует

 

№86730-11-2010 18:10:37

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Firefox 3.6
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Что касается libcupsys2. Как я понял из разных описаний установки, в последних версиях Убунту эта библиотека называется libcups2. Можно принудительно поставить libcupsys2, но за последствия я не ручаюсь.

Отредактировано igorsub (30-11-2010 18:11:03)


От оно че!

Отсутствует

 

№86830-11-2010 18:30:57

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub пишет

Что касается libcupsys2. Как я понял из разных описаний установки, в последних версиях Убунту эта библиотека называется libcups2.

Точно! Был невнимателен. 

igorsub пишет

Можно принудительно поставить libcupsys2

Как поставить принудительно?

Отсутствует

 

№86930-11-2010 20:05:49

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub пишет

Canon мог не встать из-за того, что что пакет написан под Debian

В руководстве с сайта Canon указаны инструкции по установке на две системы: Fedora 9/openSUSE 11.0 и Ubuntu 8.04. Под «Debian» имеется в виду формат .deb.

Отсутствует

 

№87030-11-2010 20:23:17

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Chrome 7.0
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Ну, я так понимаю, все упирается в использование старых библиотек. По идее нужно пинать Кэнон, но они вряд ли почешутся, это не HP.


От оно че!

Отсутствует

 

№87130-11-2010 21:24:20

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub
Так Вы можете объяснить, как принудительно установить пакет?

Как называется процесс менеджера архивов (хочу под рутом запустить, чтобы иметь возможность сразу _распаковать_ .deb в нужные папки). Уже сделал с помощью GNOME Commander.

Нашёл информацию, что под Debian для Canon ip3600 можно использовать драйвер для ip4200 или ip4600 — на Убунту не сработало. :(

Отредактировано Радик245 (30-11-2010 21:28:40)

Отсутствует

 

№87230-11-2010 21:32:07

igorsub
бедняжечка бедняжная
 
Группа: Extensions
Откуда: Мурманск
Зарегистрирован: 03-04-2005
Сообщений: 6373
UA: Chrome 7.0
Веб-сайт

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Радик245 пишет

Так Вы можете объяснить, как принудительно установить пакет?

Взять эту библиотеку из репозиториев. Но я, если честно, не уверен, что система позволит поставить ее вместо libcups2 из-за возможных конфликтов. Есть, конечно, вариант откатиться на Jaunty. :)

Добавлено 30-11-2010 21:33:51

Радик245 пишет

Нашёл информацию, что под Debian для Canon ip3600 можно использовать драйвер для ip4200 или ip4600 — на Убунту не сработало.

Если брал с оф. сайта, то скорее всего опять уперлось в библиотеки.

Добавлено 30-11-2010 21:35:09
Менеджер архивов, используемый в Убунту по умолчанию, называется file-roller.

Добавлено 30-11-2010 21:38:51
Хм, из репозиториев jaunty ее тоже убрали. :/ Только hardy.

Добавлено 30-11-2010 21:43:15
Так-с. Попробуй скачать и поставить libcupsys2 по этой ссылке. Затем снова попробуй накатить дрова.

Добавлено 30-11-2010 21:51:35
Странно. Aptitude и apt-get утверждают, что библиотека libcupsys2 в репозиториях есть, а Synaptic говорит, что нет.

Отредактировано igorsub (30-11-2010 21:44:40)


От оно че!

Отсутствует

 

№87330-11-2010 22:02:33

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

igorsub пишет

Если брал с оф. сайта, то скорее всего опять уперлось в библиотеки.

Нет, выбирал из того, что Убунту предлагает.

Добавлено 30-11-2010 22:12:18

igorsub пишет

Так-с. Попробуй скачать и поставить libcupsys2 по этой ссылке.

Центр приложений Ubuntu пишет

This is a dummy package to ease transition to new package name.

гуглопереводчик пишет

Это фиктивный пакет для облегчения перехода на пакет с новым именем.

Отсутствует

 

№87430-11-2010 23:02:06

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Драйвер установился, но принтер не работает.

Отсутствует

 

№87502-12-2010 20:02:12

Йцукен
  
 
Группа: Extensions
Зарегистрирован: 05-06-2008
Сообщений: 4773
UA: Firefox 3.6

Re: Убунту - ось с человеческим лицом и ВОТ ТАКИМИ ГЛАЗАМИ (трафик, много)

Нашёл не фиктивный, а настоящий пакет libcupsys2: http://packages.ubuntu.com/hardy/i386/l … 2/download. Но теперь не хватает libkrb53 (>= 1.6.dfsg.2) — где взять?

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2020 Mozilla Russia GitHub mark
Язык отображения форума: [Русский] [English]