Полезная информация

Не получается решить проблему на форуме? Служба технической поддержки Mozilla Россия — support@mozilla-russia.org.

№116-05-2016 20:28:46

BAd
G0Od
 
Группа: Members
Откуда: Москва
Зарегистрирован: 01-07-2009
Сообщений: 142
UA: Seamonkey 2.39

SM и openh264.

Как подключить? Чтобы была аппаратная поддержка h264 видео в html5 на ютубе.

Отсутствует

 

№216-05-2016 20:41:42

GrearKir
Участник
 
Группа: Members
Зарегистрирован: 24-03-2009
Сообщений: 147
UA: Seamonkey 2.40

Re: SM и openh264.

https://www.youtube.com/html5 тут у вас что?

Отсутствует

 

№316-05-2016 20:58:59

BAd
G0Od
 
Группа: Members
Откуда: Москва
Зарегистрирован: 01-07-2009
Сообщений: 142
UA: Seamonkey 2.39

Re: SM и openh264.

Там вот.

Но я могу включить оставшиеся красненькие и будет всё синеньким, включив в about:config: media.fragmented-mp4.enabled true, media.fragmented-mp4.exposed true, media.fragmented-mp4.use-blank-decoder, но после обновления страницы с видео на ютубе, вместо видео запускается зелёный квадрат, а вместо звука свист. В самом браузере в разделе plugins нет openh264 кодека, хотя я его ставил отдельным пакетом. Система Gentoo linux.

Отсутствует

 

№416-05-2016 21:40:46

banbot
Moderator
 
Группа: Moderators
Зарегистрирован: 23-12-2007
Сообщений: 4666
UA: Firefox 49.0

Re: SM и openh264.

BAd
На Linux для поддержки H.264 используется ffmpeg/libav. Необходимые библиотеки стоят? Сборка, скачанная с сайта Mozilla, работает?
У меня на http://www.quirksmode.org/html5/tests/video.html H.264 видео в [seamonkey] работает. Сборка [seamonkey] с сайта Mozilla, Arch Linux.


Do you feel lucky, punk?

Отсутствует

 

№516-05-2016 23:41:08

BAd
G0Od
 
Группа: Members
Откуда: Москва
Зарегистрирован: 01-07-2009
Сообщений: 142
UA: Seamonkey 2.39

Re: SM и openh264.

banbot пишет:

Необходимые библиотеки стоят?

38   "libavcodec.so.56,60,100",
38   "libavcodec.so.56",
39   "libavcodec.so.55",

Эти только есть.

banbot пишет:

Сборка, скачанная с сайта Mozilla, работает?

Работает.

banbot пишет:

У меня на http://www.quirksmode.org/html5/tests/video.html H.264 видео в [seamonkey] работает. Сборка [seamonkey] с сайта Mozilla, Arch Linux.

Сборка с сайта показывает все три видео. А установленная из репозиториев дистрибутива не показывает h264 видео.

P.S
Похоже какая-то кривая бинарная сборка в репах Gentoo лежит.

P.P.S
Вот здорово бы было, если бы бинарные сборки с сайта запиливали ebuild для Gentoo. А то в Gentoo не кому собирать, у Gentooшников времени не хватает и из-за этого [seamonkey] часто на одну-две версии опаздывает. :)

Отсутствует

 

№617-05-2016 21:56:16

GrearKir
Участник
 
Группа: Members
Зарегистрирован: 24-03-2009
Сообщений: 147
UA: Seamonkey 2.40

Re: SM и openh264.

[seamonkey] точно должен работать при установленных системных плагинах (не браузерный) для gstreamer 0.1
А для gstreamer 1.0 раньше применялись другие параметры сборки. Не помню, какой конкретно плагин gstreamer, но при его использовании у меня не нужен никакой openh264 плагин в самом разделе плагинов браузера.

Отредактировано GrearKir (17-05-2016 21:57:00)

Отсутствует

 

№718-05-2016 18:33:17

banbot
Moderator
 
Группа: Moderators
Зарегистрирован: 23-12-2007
Сообщений: 4666
UA: Firefox 49.0

Re: SM и openh264.

GrearKir
Mozilla больше не использует gstreamer для поддержки H.264.


Do you feel lucky, punk?

Отсутствует

 

№822-05-2016 12:18:57

GrearKir
Участник
 
Группа: Members
Зарегистрирован: 24-03-2009
Сообщений: 147
UA: Seamonkey 2.40

Re: SM и openh264.

Хм. А как же оно у меня работает? openh264 не установлен. Flash выключен.
ffmpeg? надо изучить

Отредактировано GrearKir (22-05-2016 12:22:56)

Отсутствует

 

№924-05-2016 12:03:11

BAd
G0Od
 
Группа: Members
Откуда: Москва
Зарегистрирован: 01-07-2009
Сообщений: 142
UA: Seamonkey 2.39

Re: SM и openh264.

Ну я про openh264 спросил не обнаружив его в плагинах и подумал что это из-за его отсутствия не показывается видео в h264, а оказалось что бинарная сборка с этого сайта кажет h264 в тестах без openh264 плагина.

Отредактировано BAd (24-05-2016 12:06:14)

Отсутствует

 

№1030-05-2016 03:03:21

BAd
G0Od
 
Группа: Members
Откуда: Москва
Зарегистрирован: 01-07-2009
Сообщений: 142
UA: Seamonkey 2.38

Re: SM и openh264.

Собрал сегодня из реп генты seamonkey 2.38 стабильную версию, удалил бинарную 2.39 и тоже не робит h264 видео в тестах. Разобрался почему не работало. В about:config после включения подкатегорий: media.fragmented-mp4.exposed, media.fragmented-mp4.ffmpeg.enabled, надо выключить и включить обратно глобальную media.fragmented-mp4.enabled чтобы включились её подкатегории и тогда заработает.Тоже самое и с Media Source Extensions для WebM VP8, MSE & WebM VP9. При включении подкатегорий: media.mediasource.mp4.enabled, media.mediasource.webm.enabled, глобальную категорию media.mediasource.enabled надо выключить и включить и тогда подцепляются включенные подкатегории. Если включить подкатегории и не перезапустить глобальную категорию ничего не включится и перезапуск браузера не поможет, надо именно перезапустить глобальную категорию. Вышел на это методом тыка включая и выключая подкатегории в поисках конфликта. Вот не люблю я такие вещи.

Отредактировано BAd (30-05-2016 20:56:41)

Отсутствует

 

№1112-07-2016 16:46:40

Drage
Участник
 
Группа: Members
Зарегистрирован: 11-07-2016
Сообщений: 1
UA: Seamonkey 2.40

Re: SM и openh264.

[seamonkey]

BAd пишет:

Собрал сегодня из реп генты seamonkey 2.38 стабильную версию, удалил бинарную 2.39 и тоже не робит h264 видео в тестах. Разобрался почему не работало. В about:config после включения подкатегорий: media.fragmented-mp4.exposed, media.fragmented-mp4.ffmpeg.enabled, надо выключить и включить обратно глобальную media.fragmented-mp4.enabled чтобы включились её подкатегории и тогда заработает.Тоже самое и с Media Source Extensions для WebM VP8, MSE & WebM VP9. При включении подкатегорий: media.mediasource.mp4.enabled, media.mediasource.webm.enabled, глобальную категорию media.mediasource.enabled надо выключить и включить и тогда подцепляются включенные подкатегории. Если включить подкатегории и не перезапустить глобальную категорию ничего не включится и перезапуск браузера не поможет, надо именно перезапустить глобальную категорию. Вышел на это методом тыка включая и выключая подкатегории в поисках конфликта. Вот не люблю я такие вещи.

какая ось? если Windows7,то не катит,надо включить media.windows-media-foundation.enabled;true....И в диспетчере смотреть:Windows Driver Foundation (WDF) -
хост-процесс :D
Такую же фишку и IceDragon заделал...К черту DMP.туда же GMP H.264///Все выбросил...только следят,гады .Кто не верит,есть ссылка в RuBoard....

Отредактировано Drage (12-07-2016 16:59:19)

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]