Полезная информация

Заказывай стафф с атрибутикой Mozilla и... пусть все вокруг завидуют тебе! Быть уникальным - быть с Mozilla!

№126-07-2021 13:05:48

Алексей Сергеевич
Участник
 
Группа: Members
Зарегистрирован: 02-02-2021
Сообщений: 15
UA: Firefox 78.0

Видеопамять и Firefox

Недавно столкнулся с интересной проблемой: Firefox потребляет очень много видеопамяти (больше 1 Гб, как у меня), и при достижении примерно 1000 Мб появляются заметные фризы. Можно ли каким-нибудь способом решить эту  проблему, или хотя-бы "сгладить" её проявление без появления проблем с производительностью? :rolleyes:

Добавлено 26-07-2021 13:11:04
Существует ли способ автоматической очистки прошлых картинок на странице (чтобы потребление держалось меньше 1Гб), или с помошью дополнения можно этого добиться?

Отредактировано Алексей Сергеевич (26-07-2021 13:11:04)

Отсутствует

 

№201-08-2021 10:03:03

zzzephire
Участник
 
Группа: Members
Зарегистрирован: 29-12-2017
Сообщений: 807
UA: Chrome 92.0

Re: Видеопамять и Firefox

Попробуй отключить WebRender:
gfx.webrender.force-disabled = true

Отсутствует

 

№301-08-2021 16:52:38

Алексей Сергеевич
Участник
 
Группа: Members
Зарегистрирован: 02-02-2021
Сообщений: 15
UA: Firefox 78.0

Re: Видеопамять и Firefox

zzzephire пишет

Попробуй отключить WebRender:
gfx.webrender.force-disabled = true

После включения этой функции такие лаги стали наблюдаться всегда.:(

Хотя сейчас поднял частоту процессора,  и вроде бы всё нормализовалось. Спасибо за ответ!:D

Отредактировано Алексей Сергеевич (01-08-2021 17:15:15)

Отсутствует

 

№401-08-2021 19:08:01

zzzephire
Участник
 
Группа: Members
Зарегистрирован: 29-12-2017
Сообщений: 807
UA: Firefox 90.0

Re: Видеопамять и Firefox

Алексей Сергеевич пишет

После включения этой функции такие лаги стали наблюдаться всегда

Приходится выбирать: либо отдать прорисовку ЦП и высвободить видеопамять, либо оставить эту работу для ГП.
Можно попробовать совместно с параметром, указанном ↑, отключить аппаратное ускорение, но нагрузка на ЦП станет чуть больше.
layers.acceleration.disabled = true
Вдогонку можно попробовать этот параметр:
gfx.direct2d.disabled = true

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2020 Mozilla Russia GitHub mark
Язык отображения форума: [Русский] [English]