Полезная информация

Общайтесь со знакомыми и друзьями в нашем сообществе в Facebook.

№111-04-2021 22:23:34

soldatovaua
Участник
 
Группа: Members
Зарегистрирован: 20-06-2015
Сообщений: 11
UA: Chrome 86.0

Поддержка TLS 1.3

Возник вопрос: с какой версии TB полноценно поддерживает TLS 1.3?
Про прекращение поддержки TLS 1.0 и 1.1 есть, а про введение 1.3 нет.
Если ориентироваться на значения по умолчанию параметров: security.tls.version.min, security.tls.version.max и security.tls.version.fallback-limit, выходит следующее:
1) 52.9.1:
security.tls.version.min - 1,
security.tls.version.max - 3,
security.tls.version.fallback-limit - 3
То есть, по умолчанию поддержка TLS 1.3 не введена.
2) 60.9.1:
security.tls.version.min - 1,
security.tls.version.max - 4,
security.tls.version.fallback-limit - 3.
То есть, по умолчанию поддержка TLS 1.3 введена.
Однако если параметрам security.tls.version.min и security.tls.version.fallback-limit выставить "4" (попытаться работать только через TLS 1.3), выдается ошибка отправки сообщений (сам сервер TLS 1.3 поддерживает).
3) 68.12.1:
security.tls.version.min - 1,
security.tls.version.max - 4,
security.tls.version.fallback-limit - 4.
То есть, по умолчанию поддержка TLS 1.3 введена.
Если параметру security.tls.version.min выставить "4" (попытаться работать только через TLS 1.3), сообщения отправляются и приходят.
Получается, что полноценная поддержка TLS 1.3 введена только в 68 версии?

Отредактировано soldatovaua (11-04-2021 22:24:04)

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2020 Mozilla Russia GitHub mark
Язык отображения форума: [Русский] [English]