Полезная информация

Пользователи не любят читать документацию. Станьте оригинальным, будьте не как все. Ознакомьтесь с нашей базой знаний.

№109-02-2018 21:59:18

Васисуалий Лоханкин
Участник
 
Группа: Members
Зарегистрирован: 09-02-2018
Сообщений: 8
UA: Firefox 58.0

Не хочет работать userChrome.css

Здравствуйте, помогите плиз заставить userChrome.css работать:(

Папка, в которой он создан, правильная, так как созданный там же userContent.css отлично работает. (На всякий случай - c:\Users\Васисуалий\AppData\Roaming\Mozilla\Firefox\Profiles\5y5vrf6h.default\chrome\) Имя файла правильное, кодировка UTF-8. Версия мозиллы последняя - 58.0.2, система windows 7 64 bit.

Не работает ни одно свойство, заданное в userChrome.css, неважно какое. Кажется, он вообще не подключается. В инструментах разработчика на вкладке "Стили" его нет.

Его содержимое сейчас такое:

Выделить код

Код:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

#root {background:#0000ff !important;}

но это я ввел просто для проверки, последняя строчка не играет роли - какое свойство ни меняй, результата нет.

Что же я делаю не так?? Может просто не замечаю какую-нибудь тривиальную ошибку? Или что-то не так с системой или мозиллой? Где можно поискать причину? :(

Отсутствует

 

№209-02-2018 22:34:10

Coroner
Участник
 
Группа: Members
Зарегистрирован: 29-10-2012
Сообщений: 2531
UA: Firefox 58.0

Re: Не хочет работать userChrome.css

Васисуалий Лоханкин пишет:

Что же я делаю не так??

Мне путь не нравится :) Хотя если всё остальное работает, то должно и это работать.

Васисуалий Лоханкин пишет:

(На всякий случай - c:\Users\Васисуалий

Ну и желательно сразу кодировку файла userChrome.css ставить в UTF-8 (без BOM).

Добавлено 09-02-2018 22:41:06
А ещё попробуйте кавычки убрать из @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

Отредактировано Coroner (09-02-2018 22:41:06)

Отсутствует

 

№309-02-2018 22:59:19

Васисуалий Лоханкин
Участник
 
Группа: Members
Зарегистрирован: 09-02-2018
Сообщений: 8
UA: Firefox 58.0

Re: Не хочет работать userChrome.css

Coroner пишет:

Мне путь не нравится :)

Да, изначально установил с кириллицией, но вроде на этой папке едва ли не половина всех установленных программ держится, и все ОК:)

Coroner пишет:

UTF-8 (без BOM).

Coroner пишет:

кавычки убрать

Попробовал. Ничего не прокатило)

Нашел вот в инструментах разработчика на вкладке "Стили" возможность добавить стиль на лету. Загружаю дополнительно этот файл userChrome.css еще раз, и ничего. Пробую закомментировать верхнюю строчку с namespace - тогда работает. Неужели в ней ошибка? Или какой-то конфликт?:(

Отсутствует

 

№409-02-2018 23:09:32

Coroner
Участник
 
Группа: Members
Зарегистрирован: 29-10-2012
Сообщений: 2531
UA: Firefox 58.0

Re: Не хочет работать userChrome.css

Может и не нужна она? Я не в курсе в каких случаях нужна она, а в каких @namespace html url("http://www.w3.org/1999/xhtml");
Это Вам бы спросить в теме https://forum.mozilla-russia.org/viewto … 56#p753556
Там люди поопытнее :)

Отсутствует

 

№509-02-2018 23:15:28

Васисуалий Лоханкин
Участник
 
Группа: Members
Зарегистрирован: 09-02-2018
Сообщений: 8
UA: Firefox 58.0

Re: Не хочет работать userChrome.css

Coroner пишет:

Может и не нужна она?

Совсем без нее не хочет, если только вручную подключать через инструменты. Но вручную не очень удобно:D
С другим вариантом пути тоже не захотело.

Пойду попробую в ту тему спрошу)

Отсутствует

 

№610-02-2018 00:46:17

SendInfo
.
 
Группа: Members
Зарегистрирован: 14-02-2011
Сообщений: 263
UA: Firefox 42.0

Re: Не хочет работать userChrome.css

Васисуалий Лоханкин пишет:

Coroner пишет: Может и не нужна она?Совсем без нее не хочет, если только вручную подключать через инструменты. Но вручную не очень удобноС другим вариантом пути тоже не захотело.Пойду попробую в ту тему спрошу)

Нет такого #root, а есть :root Результаты поиска для "root" | MDN

Отредактировано SendInfo (10-02-2018 00:54:30)

Отсутствует

 

№710-02-2018 01:03:29

Васисуалий Лоханкин
Участник
 
Группа: Members
Зарегистрирован: 09-02-2018
Сообщений: 8
UA: Firefox 58.0

Re: Не хочет работать userChrome.css

SendInfo пишет:

Нет такого #root, а есть :root Результаты поиска для "root" | MDN

Как раз благодаря этому селектору, в соседней теме, по ссылке Coroner, проблему удалось решить! :D

Это я пытался настроить стартовую страницу, считая, что она относится к интерфейсу браузера, и ее нужно править в userChrome. Перенес настройки в userContent и все заработало!:rock:

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]