Полезная информация

Юристы зарабатывают огромные деньги и славу, оперируя хорошим знанием законов. Правила форума — простой путь к успешному общению.

№112-07-2010 19:43:38

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 5.0

Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Были у кого проблемы? Как вам русификация на 3.6? Сложно ли обновиться (буду признателен полезными ссылками)? Меня заставляет думать об обновлении одна плохая ошибка в 3.4.6 см. http://forum.mozilla-russia.org/viewtopic.php?id=45189
Так же отображение русской багзилы на аглицком языке в браузерах IE и [firefox] в ОС Windows7 cм. http://forum.mozilla-russia.org/viewtop … 85#p433185
Также в версии 3.6 возможно решен вопрос улучшенного просмотра заплаток см. http://forum.mozilla-russia.org/viewtopic.php?id=45133

Отредактировано Вопрос (12-07-2010 19:52:29)

Отсутствует

 

№226-10-2010 18:06:18

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 6.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Сейчас попробую БД с 3.4.6 залить в 3.6.2.

Отсутствует

 

№327-10-2010 10:54:17

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 6.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Вопрос пишет:

ас попробую БД с 3.4.6 залить в 3.6.2.

Как обновить [bugzilla] 3.4.6 до 3.6.2 я не понял :(

В общем поставил bugzilla-3.6.2.tar.gz
Залил БД с [bugzilla] 3.4.6 в [bugzilla] 3.6.2 командой:
mysql --user=andre -p support < Bugzilla-26.10.2010.dump

Затем открыл страничку [bugzilla] 3.6.2. Нажимаю на кнопку "Найти" и получаю:

Выделить код

Код:

Software error:
DBD::mysql::db selectall_arrayref failed: Unknown column 'isactive' in 'field list' [for Statement "SELECT id,name,classification_id,description,isactive,votesperuser,maxvotesperbug,votestoconfirm,defaultmilestone,allows_unconfirmed FROM products WHERE  id IN (?,?,?,?,?,?,?)   ORDER BY name"] at Bugzilla/Object.pm line 271
    Bugzilla::Object::_do_list_select('Bugzilla::Product', ' id IN (?,?,?,?,?,?,?) ', 'ARRAY(0x2fd46d4)', undef) called at Bugzilla/Object.pm line 248
    Bugzilla::Object::match('Bugzilla::Product', 'HASH(0x2fd4554)') called at Bugzilla/Object.pm line 174
    Bugzilla::Object::new_from_list('Bugzilla::Product', 'ARRAY(0x25b86a8)') called at Bugzilla/User.pm line 701
    Bugzilla::User::get_selectable_products('Bugzilla::User=HASH(0x22c9bb8)') called at C:/Site/Bugzilla2/www/query.cgi line 198

Отредактировано Вопрос (27-10-2010 10:58:15)

Отсутствует

 

№427-10-2010 13:25:26

banbot
Moderator
 
Группа: Moderators
Зарегистрирован: 23-12-2007
Сообщений: 4828
UA: Firefox 4.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6


Do you feel lucky, punk?

Отсутствует

 

№527-10-2010 14:08:58

small75
Участник
 
Группа: Members
Откуда: Россия, Воронеж
Зарегистрирован: 20-03-2009
Сообщений: 150
UA: Firefox 3.6
Веб-сайт

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

опять же я использую MySql Administrator
в нЁм делаю бэкап/ресторе

a checksetup.pl запускали?

Отсутствует

 

№628-10-2010 12:06:20

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 7.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Получилось!!!

В общем как я выяснил здесь есть хитрая последовательность в запуске checksetup.pl и
установке прав пользователю на новую БД. Пока не разобрался в четкой последовательности. Я уже начал думать, что пользователя с другим имением и новую БД с другим именем нельзя создавать, но оказывается можно. :)

И еще в 3.6.2 нет подсветки запросов (bug) в зависимости от критичности?

Отсутствует

 

№728-10-2010 16:18:52

small75
Участник
 
Группа: Members
Откуда: Россия, Воронеж
Зарегистрирован: 20-03-2009
Сообщений: 150
UA: Firefox 3.6
Веб-сайт

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Вопрос пишет:

... И еще в 3.6.2 нет подсветки запросов (bug) в зависимости от критичности?

у меня подсвечиваются начиная с чрезвычайной критичности

Отсутствует

 

№829-10-2010 19:40:08

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 7.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

small75 пишет:

опять же я использую MySql Administrator
в нЁм делаю бэкап/ресторе

MySQL Administrator 1.2.17

Перехожу в раздел Backup и получаю ошибку "Access violation at address 0045EE90 in module «MySQL Administrator». Read of address 00000030".

Добавлено 29-10-2010 20:06:27

small75 пишет:

Вопрос пишет:

... И еще в 3.6.2 нет подсветки запросов (bug) в зависимости от критичности?

У меня подсвечиваются начиная с чрезвычайной критичности

Если ставить 3.6.2 и использовать родную БД. Затем открыть запросы "критический" и "чрезвычайный", то видно что подсветка работает.

Если я заливаю БД с версии 3.4.4, то у меня пропадает цветовая подсветка. Я думаю, что причина в том что один специалист по БД исправил значения в БД с английского на русские вместо того чтобы поправить шаблоны. Теперь мне надо найти в БД эти надписи на русском и снова исправить на английской. Возможно после исправления у меня и заработает подсветка.

Помогите, пожалуйста, поменять тип серьезности. В какой таблице это искать? И может ли быть в этом причина? Я подозревая что и в 3.4.4 работает подсветка.

Отредактировано Вопрос (29-10-2010 20:14:02)

Отсутствует

 

№929-10-2010 22:37:14

SnowyOwl
Участник
 
Группа: Extensions
Зарегистрирован: 13-01-2007
Сообщений: 274
UA: Firefox 3.6

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Подсветка -- работает. Если меняли значения Severity -- меняйте одновременно и CSS.

Отсутствует

 

№1029-10-2010 23:19:59

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 7.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

Ура!!!!!! Я сделал это!!! ))))

Оказывается MySQL Administrator не умеет редактировать значения в БД и еще при переходе на раздел Вackup выдает ошибку «Read of address 00000030» (про нее отписался выше).
Полез в БД через командную строку. Нашел где хранятся эти серьезности «select value from bug_severity;»

Но командная строка не понимает UTF8. Начал выяснять как сделать чтобы ком. строка понимала UTF8. Оказывается можно!!! Вот http://anvarichn.livejournal.com/43752.html

Затем попробовал это http://www.sql.ru/forum/actualthread.aspx?tid=660507 и это
http://phpforum.ru/index.php?showtopic=18917 . В итоги ничего не получилось. Потом товарищи подсказали что есть MySQLMa7.8.0.2. Заменил серьезность на английский текст и вуаля подсветка заработала!!! Ура товарищи. Класс!!!
Осталось выяснить как самому устанавливать шрифт и цвет разным серьезностям. Может кто знает?

Добавлено 29-10-2010 23:23:10

SnowyOwl пишет:

Подсветка -- работает. Если меняли значения Severity --

Спасибо. Разобрался. Она работает и в 3.4.6. Столько времени меня терзал этот вопрос: "А не привиделось ли мне это подсветка?". Оказывается это было из-за неграмотного редактирования БД.

SnowyOwl пишет:

меняйте одновременно и CSS.

Хм... это чаво? Стили? Где они? Это чтобы "самому устанавливать шрифт и цвет разным серьезностям.", да?

Отредактировано Вопрос (29-10-2010 23:23:34)

Отсутствует

 

№1101-11-2010 14:01:15

small75
Участник
 
Группа: Members
Откуда: Россия, Воронеж
Зарегистрирован: 20-03-2009
Сообщений: 150
UA: Firefox 3.6
Веб-сайт

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

для редактирования данных пользую "DreamCoder for MySQL"

Отсутствует

 

№1208-11-2010 19:07:18

SnowyOwl
Участник
 
Группа: Extensions
Зарегистрирован: 13-01-2007
Сообщений: 274
UA: Firefox 3.6

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

А что мешало поправить через интерфейс [bugzilla]??

Отсутствует

 

№1309-11-2010 13:22:36

Вопрос
Участник
 
Группа: Members
Зарегистрирован: 02-06-2010
Сообщений: 272
UA: Chrome 7.0

Re: Обновления с 3.4.6 (ru: 3.4.3) до 3.6

SnowyOwl пишет:

А что мешало поправить через интерфейс ??

Проверил. Можно. Мешало незнание, а раньше не судьба была ответить? :)

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]