Полезная информация

Будьте в курсе последних изменений в мире Mozilla, следя за нашим микроблогом в Twitter.

№109-09-2019 05:38:36

fifer
Участник
 
Группа: Members
Зарегистрирован: 09-09-2019
Сообщений: 1
UA: Firefox 69.0

Не работает аппаратный декодер VP9

ФФ не использует аппаратный декодер видео
media.mediasource.webm.enabled = true
1.jpg

DXVA Checker сообщает что поддержка VP9 есть
2.jpg

Тоже самое видео без проблем аппаратно декодится в MPC-BE
3.jpg

Система :
Ryzen 3400G + Vega 11
Windows 10 LTSC
Firefox 69

Отсутствует

 

№219-10-2019 01:52:24

TAM-TAM
Участник
 
Группа: Members
Зарегистрирован: 19-10-2019
Сообщений: 1
UA: unknown 0.0

Re: Не работает аппаратный декодер VP9

Наверняка потому, что у вас в системе Windows 10 LTSC не установлен VP9. MS его убрали из системы после версии LSTB. Вам сюда -
https://github.com/M1k3G0/Win10_LTSC_VP9_Installer

Отредактировано TAM-TAM (19-10-2019 01:53:44)

Отсутствует

 

№301-11-2019 12:02:52

zzzephire
Участник
 
Группа: Members
Зарегистрирован: 29-12-2017
Сообщений: 569
UA: Firefox 70.0

Re: Не работает аппаратный декодер VP9

fifer пишет

ФФ не использует аппаратный декодер видео

Была аналогичная проблема. Имею видеочип GTX 1060. Проблема решилась установкой параметра media.wmf.dxva.d3d11.enabled = true (был установлен в false)
Сэмпл для проверки VP9

Отредактировано zzzephire (04-11-2019 10:53:13)

Отсутствует

 

№425-07-2020 20:09:50

zzzephire
Участник
 
Группа: Members
Зарегистрирован: 29-12-2017
Сообщений: 569
UA: Firefox 78.0

Re: Не работает аппаратный декодер VP9

В предыдущем посте я написал какую-то ересь :usch:
Проблема с VP9 у [firefox] имеется (проверено на 78.0.2 х64). Но это скорее баг, не относящийся к самому декодеру.
Далее по мотивам поста с реддита о данной проблеме. Из-за падения (краша) [firefox] делает об этом отметку в настройках профиля благодаря которой, по неизвестным причинам, отключается аппаратное декодирование VP9. Если нет VP9, то не будет вам и видео в высоком разрешении (выше FHD) на видеосервисах, его использующих. Зайдите в about:config и найдите параметр gfx.crash-guard.status.wmfvpxvideo если он = 3, значит декодер VP9 у вас на данный момент не будет активен.
Решение такое: установить параметр gfx.crash-guard.status.wmfvpxvideo = 2 а также добавить в user.js строку вида:

user_pref("gfx.crash-guard.status.wmfvpxvideo", 2);

Параметр часто и по непонятным причинам переключается на = 3, поэтому его нужно добавить в user.js как = 2.
После этого перезагрузите [firefox] и всё должно работать.

Скриншот
e9752bd194d7108e296629fb84d799e7.jpg

Отредактировано zzzephire (03-10-2020 15:57:53)

Отсутствует

 

№526-07-2020 12:59:39

_zt
Участник
 
Группа: Members
Зарегистрирован: 10-11-2014
Сообщений: 909
UA: Firefox 68.0

Re: Не работает аппаратный декодер VP9

zzzephire
Вот это расширение вроде контролирует статус кодеков.
https://addons.mozilla.org/ru/firefox/a … ed-h264ify
VP9 должен быть установлен в системе. YouTube на vp9 не работает, у меня, требует h264, иначе заглушки выдает вместо видео.


Fx 91 esr

Отсутствует

 

№626-07-2020 16:46:54

zzzephire
Участник
 
Группа: Members
Зарегистрирован: 29-12-2017
Сообщений: 569
UA: Firefox 78.0

Re: Не работает аппаратный декодер VP9

_zt
Мы имели в виду аппаратное декодирование VP9. Для этого оно в первую очередь должно поддерживаться видеочипом, а уже потом драйвером

Отсутствует

 

№726-07-2020 20:13:49

sn260591
Участник
 
Группа: Members
Зарегистрирован: 26-09-2015
Сообщений: 88
UA: Firefox 78.0

Re: Не работает аппаратный декодер VP9

_zt
Данное расширение только обманывает сайты об поддерживаемых браузером форматах.

Отсутствует

 

№826-07-2021 12:03:03

pakos2835
Участник
 
Группа: Members
Откуда: москва-воронеж не догонишь
Зарегистрирован: 11-09-2013
Сообщений: 12
UA: Firefox 90.0

Re: Не работает аппаратный декодер VP9

TAM-TAM пишет

MS его убрали из системы после версии LSTB

у меня ltsb 1607 и не работает youtube vp9,
флаги стоят нормально, поддержка в гпу (gm206) vp9 декодирования есть,

как включить в браузере?

Отсутствует

 

№928-09-2021 11:17:35

pakos2835
Участник
 
Группа: Members
Откуда: москва-воронеж не догонишь
Зарегистрирован: 11-09-2013
Сообщений: 12
UA: Firefox 92.0

Re: Не работает аппаратный декодер VP9

:blush: вопрос проблемы локализовался не в браузере. а в версии виндовс. она не содержала пакет поддержки кажется

Отсутствует

 

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2020 Mozilla Russia GitHub mark
Язык отображения форума: [Русский] [English]