Проблема в том что сайт перестал корректно обрабатывать символ "+" в поисковом запросе. Например по запросу через поисковый плагин в адресной строке выводится "https://plati.com/search/Dark+Souls" и ничего не находится, но если сделать запрос "Dark Souls" через форму на сайте, то в адресной строке "https://plati.com/search/Dark Souls" и всё благополучно находится.

Можно ли настроить поисковый плагин так, чтобы вместо символа "+" был в запросе пробел между словами ?

Вот так корректно обрабатывает:
https://plati.com/search/Dark%20Souls

Да и так тоже:
https://plati.com/search/Dark Souls

Значит, просто убрать символ "+".

Открыть xml в блокноте или лучше отредактировать сразу в search.json.mozlz4.

На форуме есть хорошая кнопка для этих целей. Из этой темы.

>Да и так тоже: https://plati.com/search/Dark Souls

Я об этом как раз написал вначале.

>Значит, просто убрать символ "+".

Firefox автоматически заменяет пробелы на +.

В FF нужно вручную добавлять поиск для этого сайта. Не стал заморачиваться.
В хроме за 5 сек добавил поиск, открыл запрос. Вместо пробела %20.
Нормально ищется.

%20 это и есть пробел.
Я рад что в Хроме всё нормально.

oopsididagainster
Может здесь получится...
Search Engine Creator :: Дополнения Firefox

thrower пишет:

В FF нужно вручную добавлять поиск для этого сайта. Не стал заморачиваться.

Ок. Позаморачиваюсь.

oopsididagainster пишет:

сайт перестал корректно обрабатывать символ "+" в поисковом запросе

Неа. Это ты просто id формы не указал.

Вот тебе готовый "поисковый плагин":

PlatiRu.xml

Выделить код

Код:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/spec/opensearch/1.1/">
<os:ShortName>Plati.ru</os:ShortName>
<os:Description>PLATI for oopsididagainster</os:Description>
<os:InputEncoding>UTF-8</os:InputEncoding>
<os:Image width="16" height="16">data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAABp0lEQVQ4jZVRv2sUURAeFEERwSIYorns+6awsE4sFBsLa1FSiYUIKVJYJQoG5IiNEryD252JtWlEEbQRUtgYTSH+D8GkCUTIZd9MERDXYm+PRC+b+MEr3sx8P4YhqoEL3pvys7qZPraeD53xdjKyt2aCZZPQqv7NJh372Rq98H2KTvzr1k5GXPE7Ck8fnIgXXfnHgSlMMGMSHhIR7QhPeIbHlmG2myYo+6FlwneOtJILvrly4cqFKV4diVQh13CzIpcPv7bbIQx2Uky5YNUV2R731crZFJ9duYiCeSKiuDB8zpQ/moZHecYXKaZ82wRLLpgjIoqS3Kqc30zScRfcd+XChdeJiDYXhk+78NeoeBo7Y5cGJOIvPcJLIqKttHHelXfLROFe7e4muFG5d9PGeL+e4UVPdKVeQPlTKRCeRMWkKxcmeG2CpUo47+DaYHKGu9XQWjOcjIL5/ZfoX+TDQIGYhQeuXFiG2fISvFLGxlxMk+su/M6F113wtnYNIqKN1ugpF5grF3k6dvVQwt/opo3xXuTd7XY4+98COx1cNsFyLsmVw2b/ALdqAmyMg2+BAAAAAElFTkSuQmCC</os:Image>
<SearchForm>http://plati.com/</SearchForm>
<os:Url type="text/html" method="GET" template="http://plati.com/search/">
  <os:Param name="searchstr" value="{searchTerms}"/>
</os:Url>
</SearchPlugin>

oleg.sgh
Спасибо, пригодится в будущем когда разберусь с ним.

thrower
Помогло, спасибо!
Оказалось дело не в плюсиках в адресной строке в запросе, а в плагине импортированом в search.json.mozlz4 ранее, похоже он просто устарел.