Windows 7, включено стандартное сглаживание, ClearType выключен. Firefox 45 ESR с новым профилем.

С выключенным аппаратным ускорением шрифты выглядит так - все хорошо.
С включенным - так. Как видно, часть шрифтов мылится из-за субпиксельного сглаживания, что меня не устраивает. Причем если в HTML-инспекторе, например, у заголовка сменить размер шрифта на 10px (значение должно быть меньше 16px), то сглаживание сразу пропадает.

Можно подумать, что тут помогут такие параметры как gfx.font_rendering.cleartype_params.force_gdi_classic_max_size и gfx.font_rendering.cleartype_params.force_gdi_classic_for_families, но у меня они не оказывают никакого эффекта. Перебрав различные комбинации в about:config?filter=font_rendering, я ничего добиться не смог. Дополнение Anti-Aliasing Tuner предлагать не надо, он эти же параметры и меняет.

Отключение аппаратного ускорения - плохой вариант.

Решения?

Попробуйте
gfx.font_rendering.directwrite.enabled;false
gfx.direct2d.disabled;true
И да, все параметры связанные с аппаратным ускорением требуют рестарта для применения.

turbot пишет:

gfx.font_rendering.directwrite.enabled;false

Не дает никакого эффекта.

turbot пишет:

gfx.direct2d.disabled;true

->

Esper пишет:

Отключение аппаратного ускорения - плохой вариант.

gfx.font_rendering.graphite.enabled;false (хотя его вроде только после 45-ой включили)
и
layers.deaa.enabled;false (не уверен, что он вообще к тексту применяется)
Больше ничего в голову не приходит.

turbot пишет:

gfx.font_rendering.graphite.enabled;false

Никак не влияет, да и сразу в false стоит, это скорее к настройкам безопасности относится.

turbot пишет:

layers.deaa.enabled;false

Это для Linux и OS X.

Проблема в том, что где-то зашито значение размера шрифта, выше которого включается ClearType при включенном аппаратном ускорении.

Esper пишет:

это скорее к настройкам безопасности относится.

http://scripts.sil.org/cms/scripts/page … te_firefox

Проблема в том

Чем мог. Никогда не задавался целью отключить сглаживание шрифтов.

Esper
Попалось тут, попробуйте.

If you have clear type disabled it now comes on by default, even in XP. They added skia to "gfx.content.azure.backends" and so removing that disables clear type again.

Попытался самостоятельно решить  эту же проблему как у топик-стартера. Ни чего не выходит :(
На винде XP сработало gfx.content.azure.backends
А на 7 срабатывает только gfx.direct2d.disabled
Может у кого-нибудь получилось добиться отображения шрифтов как с включённым gfx.direct2d.disabled, но только без отключения direct2d ?

Кстати, в хроме отключение аппаратного ускорения не отключает замыливание шрифтов, но отключает всё остальное :lol: отдельные пользователи хрома сильно негодуют по этому поводу.

Подниму тему, проблема все еще открыта.

Есть какая-то дурацкая зависимость между font-family шрифта, его размером и аппаратным ускорением.

Частично "мыло" убирается блокировкой сторонних шрифтов, которые подгружают страницы. Причем блокировкой именно *.woff/*.ttf через Adblock и подобные расширения, потому что использование browser.display.use_document_fonts = 1 иногда дает побочный эффект (включаются непривычные шрифты на некоторых страницах). Плюс сейчас популярно делать элементы интерфейса с помощью символов из шрифтов - через расширения можно включать их в вайтлист (gfx.downloadable_fonts.enabled криво работает).

Даже не знаю, куда тут еще можно смотреть. Возможно какое-то влияние оказывают системные шрифты с перманентым ClearType сглаживанием (типа Segoe UI).

Видеодрайвер?

Firefox 52, по-моему, теперь даже отключение аппаратного ускорения не решает проблему. Есть идеи, как сделать шрифты так, как тут?
Оказывается, теперь помимо отключения HWA надо еще и gfx.content.azure.backends править. Спасибо, turbot.

littleleshy пишет:

Видеодрайвер?

Что с ним?