Добрый день.

Фаерфоксом пользуюсь много лет. проблем как таковых с ним никогда не было.

Но как говорится "и на старуху бывает проруха".

Сегодня включил комп, и часть сайтов стала вдруг отображаться плохо.

Вот скрин гугла http://i58.fastpic.ru/big/2015/0421/30/9df33328affc32520cc917b8b77a7c30.png

А вот, если убрать галку "Разрешить вебсайтам использовать свои шрифты вместо установленных" http://i58.fastpic.ru/big/2015/0421/16/a395393c816d53950090b49eb18e5d16.png


Я и firefox переустанавливал, и обнулял профиль. Не помогает.


Подскажите, что делать?

В других браузерах то же самое?

В других -  все как положено.

Ctrl+Shift+C, выбрать элемент с отсутствующим текстом, справа перейти на вкладку Шрифты — какой шрифт используется (https://developer.mozilla.org/ru/docs/T … View_fonts)?

на сайте google.ru (как на скрине в первом посте)

Выделить код

Код:

Arial Negreta системный
Используется как: "Arial"

на сайте mail.ru в почтовом ящике

Выделить код

Код:

Arial системный
Используется как: "Arial"

Попробовал в Настройки -> содержимое -> шрифт по-умолчанию      выбрать Arial

Эффект тот же. Пропадает текст на странице как в картинке в первом посте.

Нечего не пойму.

Пользуюсь браузером с утра до вечера каждый день. Никаких системных изменений со вчерашнего дня не делал. Никакого софта не ставил. Кстати ОС у меня  Xubuntu 14.04.

Есть еще идеи?

За ранее спасибо всем отвечающим.

antonmayko
Аппаратное ускорение попробуйте отключить.
И проверьте работу в безопасном режиме

Откуда взялся шрифт «Arial Negreta»?  Вот здесь кому-то помогла установка шрифтов от Windows.  Наверное, Arial Negreta установлен, но не имеет какого-то свойства, а соответствующего шрифта с этим свойством нет.

Узнать, какие установлены шрифты, можно с помощью fc-list и grep.

21-04-2015 17:43:16

antonmayko пишет:

Я и firefox переустанавливал, и обнулял профиль. Не помогает.

Кстати к отключению аппаратного ускорения: что означает «обнулял профиль»?

banbot пишет:

antonmaykoАппаратное ускорение попробуйте отключить.И проверьте работу в безопасном режиме

Проверил с отключенным аппаратным ускорением и в безопасном режиме еще проверил. Без результата.

Я дико извиняюсь за созданную панику. (просто firefox - мой любимый браузер)

Ситуацию исправил.

Firefox оказался ни при чем. сломались почему-то шрифты в папке /usr/share/fonts/truetype/msttcorefonts

Свои шрифты из этой папки я удалил. Затем залез в свой ноутбук и скопировал шрифты из одноименной папки.

Включил назад аппаратное ускорение. и Поставил галку  "Разрешить вебсайтам использовать свои шрифты вместо установленных"

ВСЕ РАБОТАЕТ!!!!

Всем СПАСИБО!!!!

antonmayko пишет:

сломались почему-то шрифты в папке /usr/share/fonts/truetype/msttcorefonts

Свои шрифты из этой папки я удалил. Затем залез в свой ноутбук и скопировал шрифты из одноименной папки.

А ещё можно было попробовать переустановить пакет. Например, в aptitude это (без отдельных удаления и установки) Shift-L.

Узнать локально, из какого пакета установленный файл, можно с помощью dpkg --search файл

Пакеты со шрифтами я переустанавливал, и генерировал заново кеш шрифтов. Не помогло.