Всем привет.
Я верстаю сайт, хочу чтобы он во всех браузерах (исключая древние) отображался нормально.
От сюда вопрос - какие версии firefox стоит установить, чтобы проверить корректность отображения сайта? Иными словами, какие версии были изменены так, что html разметка и css стили в этих версиях воспринимаются браузером по разному?
Сейчас установил firefox 5.0 и последняя версия есть. Какие еще версии нужно установить? Думаю ниже пятой не стоит ставить.
Наверно 12 версию надо, потому что с 5-ой версии firefox обновляется до 12, и только потом до 15.

Последний стабильный ставьте и все.

Найдите [firefox] 3.6, не прогадаете. Кстати, для [ie] есть IETester.

littleleshy пишет:

Найдите [firefox] 3.6, не прогадаете. Кстати, для [ie] есть IETester.

Да я нашел, только он что-то не ставится. Говорит, что не является приложением Win32.

qazibum пишет:

Да я нашел, только он что-то не ставится.

o_0, зачем его ставить-то? http://portableapps.com/apps/internet/f … n#legacy36

qazibum пишет:

Говорит, что не является приложением Win32

Установщик битый или левый.

littleleshy пишет:

qazibum пишет:

Да я нашел, только он что-то не ставится.

o_0, зачем его ставить-то? http://portableapps.com/apps/internet/f … n#legacy36

qazibum пишет:

Говорит, что не является приложением Win32

Установщик битый или левый.

Спасибо за portable версию.
Качал 3,6 от сюда http://mozilla-russia.org/products/firefox/history.html#release
Сейчас еще раз попробовал, вообще нулевой файл скачал. Какой-то глюк там наверно.

ИЕТерстер мало того, что нестабильный, так ещё и отображает иногда не так, как в оригинальных Ишаках. С Ишаками только виртуалка катит, можно попробовать посмотреть в сторону IECollection, но тут тоже не всё гладко, ещё есть всякие платные решения.
Режим эмуляции старых версий в самом Ишаке тоже на 100% не совпадает.

По поводу ФФ стоит глянуть статистику интернетов по браузерами и версиям, прикинуть во что обойдётся поддержка и ради чего, нужно учитывать аудиторию сайта, если айтишная направленность, то статистика сайта точно не будет совпадать с общеинтернетовой.

Не всё так просто.

KooL пишет:

ИЕТерстер мало того, что нестабильный, так ещё и отображает иногда не так, как в оригинальных Ишаках. С Ишаками только виртуалка катит, можно попробовать посмотреть в сторону IECollection, но тут тоже не всё гладко, ещё есть всякие платные решения.
Режим эмуляции старых версий в самом Ишаке тоже на 100% не совпадает.

По поводу ФФ стоит глянуть статистику интернетов по браузерами и версиям, прикинуть во что обойдётся поддержка и ради чего, нужно учитывать аудиторию сайта, если айтишная направленность, то статистика сайта точно не будет совпадать с общеинтернетовой.

Не всё так просто.

IECollection буду сейчас ставить. Но вообще можно на вирт.машине решить эту проблему, нудно правда.
Сайт такой тематики, что браузеры самые разные. Даже с ff 1.0 заходили в этом месяце.
Поэтому надо выяснить какие версии ff нужно ставить для тестирования сайта. 3.6 точно буду, а дальше?

ESR и последнюю стабильную. Да и от 3.6 отучать давно пора для их же блага.

У меня Ишаки на ХР Моде крутятся, жрёт мало, запускает быстро, интеграция с рабочим столом, Ишаки оригинальные.

KooL пишет:

ESR и последнюю стабильную. Да и от 3.6 отучать давно пора для их же блага.

У меня Ишаки на ХР Моде крутятся, жрёт мало, запускает быстро, интеграция с рабочим столом, Ишаки оригинальные.

Можно подробнее?

Для [firefox] портативной из папки FirefoxPortable15\Other\Source\ файл FirefoxPortable.ini перенести в коневую папку portable и параметр AllowMultipleInstances=false поставить в true

с таким параметром можно одновременно запускать несколько [firefox]

Версии [firefox] предлагаю 3.6, 10 esr, 16. Есть еще SeaMonkey тот же [firefox] по сути, форк.

qazibum
Про ХР Мод? Где-то примерно так я делал:
http://www.sitepoint.com/ie6-ie7-ie8-win7-xp-mode/

Минимум - то, что в папке релизов

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/

2.0.0.20
3.0.19-real-real
3.6.28

ну и 10.08 только что появился.

Под 2.*, 3.0.* и 3.5.* версии верстать точно не надо.
Да и 3.6.* под вопросом.
Вот под ESR (default), текущую release — стоит. И можно присмотреться к тестовой nightly.