Xочется чтобы при клике по файлу (любого типа) он сразу бы начинал скачиваться без всяких окошек, запросов, дополнительных действий.

Пробовал плагины Flashgot, Do this automatically, Normal "open in" dialog и по очереди, и все вместе и все комбинации...
Ничего не помогло. Пробовал с чистой лисы. Эффект нулевой.

Теоретический так http://s49.radikal.ru/i125/1106/02/d7694b9f20b8.png
Попробуйте, точно не знаю.

remus
Отлично замазали название архива :D

VeRtex, Упс, изменил пост )) А вообще должно же сохранять без каких либо запросов... Ну я так думаю...

remus пишет:

А вообще должно же сохранять без каких либо запросов... Ну я так думаю...

Я проверил данный метод на *.PDF. Сохраняет. Только раздражает мимолетное появление новой вкладки.

VeRtex, Вот и хорошо, может и мне пригодиться когда нибудь, а он через всякие дополнения пытался сделать  в итоге не смог :D

На самом деле там есть некоторая проблема, допустим если я ставлю пункт сохранить и "выполнять автоматически", то тогда файлы сохраняются сразу, но если выбрать открывать файл (пресловутые торренты) и конечно галочку "выполнять автоматически" то окошечко с выбором таки появляется:/

Kamui
Это старый баг. И, видимо, его не исправят даже в Firefox 7.

А что делать, если checkbox неактивен?
http://img198.imageshack.us/img198/7681/121212121212121212.jpg

Попробуйте скачать файл незарегистированного типа (с расширением dda, например). У вас тот же результат будет, что и у меня?
Если не знаете где такое скачать: создайте файл с таким расширением, прикрепите к письму и отправьте на свой e-mail. А потом это вложение попробуйте скачать. Я так тестировал.

Во вкладке "Инструменты - Настройки - Приложения" такого типа нет (как и многих других).

http://forum.mozilla-russia.org/viewtopic.php?id=39820

pi.v.vitaly, сейчас не помогает.
wolfxr, я в первом посте написал, что я это пробовал, но оно не помогло.

prevet3847
А удаление файла mimeTypes.rdf в профиле помогает?

MySh, удалил - не помогло. :cry:

Что ж, придется писать костыль.