Есть почтовик, работающий на KMS 6.09.
В нём используется довольно обширная база контактов.
На сегодняшний день все юзеры работают через web-интерфейс (встроенный в KMS).
Это не очень удобно. Хочется переехать на TB - оч. понравилось через IMAP.
Одна проблемма: не получается подключиться к адресной книге по LDAP.
В мануале KMS расписан пример для Outlook Express - не помогло.
Изучил статью Connecting Mozilla / Netscape Address Book to Active Directory - тоже не помогло.
Читал форум. Много думал. Не помогло.

Настройки TB следующие:

Имя: МоёПроизвольноеИмя
Сетевое имя сервера: ip.адрес.моего.сервера
Базовое отличительное имя: fn=ContactRoot (либо пусто, как рекомендует мануал KMS)
Номер порта: 389 (либо 636 - дефолтно в зависимости от использования SSL)
Регистрироваться с помощью имени пользователя и пароля: dc=username, dc=MyDomainName, dc=ru

По последнему пункту честно говоря не совсем понятно: как указать пароль?
И вообще, может здесь нужно писать что-то совершенно другое?


На вкладке "Автономно" нажимаю кнопку "загрузить".
Думает несколько секунд (появляется окошко "репликация")... и всё!
Окошко закрывается - записи не появляются.

Если стоит галочка "Использовать защищённое соединение (SSL)" - спрашивает имя пользователя и пароль.
Вне зависимости от введённых данных - результат тот же.
Что я делаю неправильно?

Barvinok пишет:

Есть почтовик, работающий на KMS 6.09.
В нём используется довольно обширная база контактов.
На сегодняшний день все юзеры работают через web-интерфейс (встроенный в KMS).
Это не очень удобно. Хочется переехать на TB - оч. понравилось через IMAP.
Одна проблемма: не получается подключиться к адресной книге по LDAP.
В мануале KMS расписан пример для Outlook Express - не помогло.
Изучил статью Connecting Mozilla / Netscape Address Book to Active Directory - тоже не помогло.
Читал форум. Много думал. Не помогло.

Настройки TB следующие:

Имя: МоёПроизвольноеИмя
Сетевое имя сервера: ip.адрес.моего.сервера
Базовое отличительное имя: fn=ContactRoot (либо пусто, как рекомендует мануал KMS)
Номер порта: 389 (либо 636 - дефолтно в зависимости от использования SSL)
Регистрироваться с помощью имени пользователя и пароля: dc=username, dc=MyDomainName, dc=ru

По последнему пункту честно говоря не совсем понятно: как указать пароль?
И вообще, может здесь нужно писать что-то совершенно другое?


На вкладке "Автономно" нажимаю кнопку "загрузить".
Думает несколько секунд (появляется окошко "репликация")... и всё!
Окошко закрывается - записи не появляются.

Если стоит галочка "Использовать защищённое соединение (SSL)" - спрашивает имя пользователя и пароль.
Вне зависимости от введённых данных - результат тот же.
Что я делаю неправильно?

Попробуй так
в поле base dn ввести o=acmecorp,c=ru
В advance фильтр (objectclass=*)
и брать все дерево
acmecorp заменить на имя домена

На вкладке "Автономно" нажимаю кнопку "загрузить".
Думает несколько секунд (появляется окошко "репликация")... и всё!
Окошко закрывается - записи не появляются.

Похожий глюк, сегодня экспериментил.
На вкладке "Автономно" нажимаю кнопку "загрузить" - записи тоже не появляются.
Но когда я набираю имя в "Панели поиска" - сразу все появляется :)
LDAP на Exchange 5.5

По последнему пункту честно говоря не совсем понятно: как указать пароль?

Пароль в Thunderbird всегда указывается при первом подключении к чему-либо, что требует пароля.
Он так сделан.

имя пользователя задается в поле  cn, т.е
cn=user,dc=mydomain,dc=com
после коннекта ТБ сам попросит пароль

Попробовал все приведённые рецепты. Безрезультатно.

nn-zh пишет:

в поле base dn ввести o=acmecorp,c=ru
В advance фильтр (objectclass=*)

По повду base dn в руководстве KMS написано следеющее:

Search base
If you want to access all public, shared and your own files, leave this entry blank or
insert
fn=ContactRoot

В advance фильтре (objectclass=*) стоит по умолчанию.
Вообще этот фильтр - большой глюк. Попробуйте написать там что-нить по русски.