C некоторого момента( привязать не к чему не могу) перестали уходить письма со вложениями(jpg, архивы).
Использую три различных SMTP сервера( один из них gmail.com), ни через один из них вложения не уходят.
При попытке отправить письмо со вложением получаю ошибку "Сообщение не может быть отправлено,
потому что невозможно установить соединение с SMTP сервером.
При этом письма без вложений и со вложениями необльших txt файлов уходят без проблем.
Пробывал отключать антивирус Avast и встроенный firewall - не помогает.
Установил The Bat - через него файлы со вложениями уходят без проблем.
Поставил Thunderbird 3.0b - та же ошибка.

Подскажите, пожалуйста в чем может быть дело.
Переходить на другую программу не хочется - много настроек,
фильтры и привычка работать с Thunderbird.

Заранее спасибо за любую помощь.

та-же ситуация с smtp.mail.ru

у меня таже проблема....
письма бывает уходят... но после перезагрузки компа... но и то не всегда....
засада....  кто как с этим боролся ?
проблема с smtp.mail.ru и smtp.inbox.ru
версия правда 2.0.0.23
закономерности не нашел ...
хоть русские символы хоть английские....
правда заметил что офисные не упакованые файлы чаще не отправляются....
глюк этот уже начал доставать

что никто не знает как это ремонтируется????
разработчики мозиллы!!!

Dimorus
Разработчиков тут нет, только пользователи.

ээээ а в тех поддержку разработчикам как написать?

http://bugzilla.mozilla.org или http://feedback.mozilla.org

У Вас случайно расширение на автоархивирование не стоит? Если стоит, то отключите и попробуйте. Должно помочь

стоит только одно расширение. для того чтоб в трее висело всегда...  MinimizeToTray 1.5
больше нет никаких нету.... где косяк фиг его знает...

сейчас отключил все расширения....

создал чистое письмо....
отправил его..оно ушло...
создаю следующее НИЧЕГО не меняя!!! тока прикрепляю файлик.. ЛЮБОЙ размер... хоть 1 кб.... любого формата... не отправляется...
тут же его удаляю прикрепленый файл.. нажимаю отправить... и оно Уходит!!! О_О без прикрепленного ФАЙЛА!!!
офИГЕТЬ!!! КААК ТАК???

кстати пытался отправить много раз на support@mozilla.ru но так ответа и не последовало....

На вирусы проверяйся.

banbot пишет:

На вирусы проверяйся.

вирусов точно нету
это первое что я сделал....
и даже если перенести ящик мозиллы на другой комп.и там запустить нафига не меняется....
таже ситуевина.... вот хочу узнать где конфиги для отправки сообщений хранятся?

Это не из-за вирусов. Там надо смотреть разрешения на временную папку, в которую Thunderbird кладет временный файл перед отправкой. Из-за отсутствия прав на запись в эту папку и вылетает такая шляпа.

DelSa

У человека стоит Windows XP. Какие разрешения?

TLemur, а в чем проблема? На ХР кто-то уже отменил разрешения?

А куда оно ложит? и где это посмотреть?
У меня там стоит Win XP Home....
там вроде вообще никакие разрешения нельзя выдавать...?

может посоветуете проги для регистрации проходящего трафика?
может с помощью них можно будет определить где чего застривает.... :sick:
желательно чтоб они регистрировали вобще все что происходит... :)
или хотя бы чтоб все почтовые порты отслеживало... :)

или может есть дополнения которые это умеют?

DUMeter например.

Кстати да. А вот насчет дополнений, не уверен, что они могут без помощи внешней программы учесть весь трафик.

Dimorus пишет:

А куда оно ложит? и где это посмотреть?
У меня там стоит Win XP Home....
там вроде вообще никакие разрешения нельзя выдавать...?

Загрузите Windows XP Home Edition в Safe Mode, и, о чудо :) , при условии, что диск отформатирован в NTFS, в контекстном меню дисков, папок и файлов появится пункт "Безопасность" - разрешения смотрятся и выдаются в нем.
:offtopic: В NT 6.0 (Windows Vista) и NT 6.1 (Windows 7), домашних редакций, для раздачи прав на объекты NTFS уже не требуется таких извращений - пункт "Безопасность" доступен всегда.

DelSa пишет:

Это не из-за вирусов. Там надо смотреть разрешения на временную папку, в которую Thunderbird кладет временный файл перед отправкой. Из-за отсутствия прав на запись в эту папку и вылетает такая шляпа.

куда почтовик ложит файлы временные*?)

ru-vadik

А если диск в FAT32?

Dimorus пишет:

куда почтовик ложит файлы временные*?)

В системную переменную %Temp%, естественно.

TLemur Во всех версиях FAT разграничение по правам отсутствует.

А может поскажете всеже.. какие проги могут вообще все данные регистрировать?
не просто трафик показывало... а чтоб показывало что и куда полезло?
и потом отфильтровать?

после анализа пакетов... было сообщено что действительно косяк в проге....
пишем запрос в англо-язычную  багзилу:)) :music:

Тоже столкнулся с этим на версии уже 2.0.0.23, когда была необходимость отправить письмо с аттачем. Счас обновился до 3.0, баг остался.
Сидит в обработке исходника письма с аттачем, конкретно - заголовочного поля Content-Disposition:

Content-Disposition: attachment;
filename="file.jpg"

Судя по RFC 822 оно, как и другие, должно приходить на сервер одной строкой:

Content-Disposition: attachment; filename="file.jpg"

Похоже, не работает сворачивание полей письма при отправке, либо всех, либо только конкретно этого. Это то, что в указанной доке называется как "unfolding".

В общем, когда очень надо отправить письмо с аттачем через любимый буревестник, надо ручками учить его летать :)
Сохраняем как черновик готовое к отправке письмо, ищем его в каталоге/файле черновиков учетной записи либо локальной папки (в зависимости от того, что указано в свойствах учетной записи насчет хранения черновиков), находим исходник своего письма, выпрямляем указанную строку о нашем аттаче и отправляем письмо.
Исходник письма в версии 3.0 удобно посмотреть через "другие действия->показать исходник", но открывается только на чтение.
К примеру, юзаю портабельную версию. Черновик лежит в файле:
...\ThunderbirdPortable\Data\profile\Mail\Local Folders\Drafts
Искать свое письмо там удобно по увиденному в заголовке числу линии boundary.

Кстати, обнаружил в этом файле сохраненные черновики когда-то написанных писем. Непонятно, зачем их хранить-то. В окне громоптицы не видны, а файлец уже нехилый по размеру, учитывая то, что аттачи здесь же в теле письма. Удалил содержимое файла черновиков, птичка промолчала :)

Можно так же выправить поле Content-Type, где упоминается имя файла аттача, хотя отправка работает и без этого действия.

Пойду прогуляюсь на багзиллу...

Вот мне странно - где вы все эти "баги" находите? Сто лет пользуюсь ТВ, начиная аж с версии 0.х, и чтобы не  я не смог отправить письмо с аттачем, даже представить себе не могу такую ситуацию, а, тем более, ее воспроизвести.

В общем, когда очень надо отправить письмо с аттачем через любимый буревестник, надо ручками учить его летать :)
Сохраняем как черновик готовое к отправке письмо, ищем его в каталоге/файле черновиков учетной записи либо локальной папки (в зависимости от того, что указано в свойствах учетной записи насчет хранения черновиков), находим исходник своего письма, выпрямляем указанную строку о нашем аттаче и отправляем письмо.

Первый раз слышу о таких диких плясках с бубном. Может вовсе не ТВ вовсе надо учить летать? :)

я вот в англоязычной багзиле оставил свой баг:
https://bugzilla.mozilla.org/show_bug.cgi?id=534019
да и этот баг у меня тока на 1 компе появляется из 10 .... 
я этот комп уже убить готов.....
не знаю в чем дело....

та же ситуация с smtp.mail.ru

В [thunderbird] письма с вложениями не проходят
А TB тоже выдает ошибку с вложением (хотя письма проходят с вложениями)

Тех поддержка mail.ru коментирует: У нас smtp работает хорошо. Используйте smtp провайдера!!! (mail.ru отдыхает)

PS: Жду решения проблемы. Пока пользую ящик на рамблере

Раз лично у Вас не проходят (а у миллионов других пользователей отправляются без проблем) - значит, как говорится: "дело было не в дрезине".

У меня была ситуация когда на mail.ru я не мог отправить почту с прикреплёнными файлами не через smtp не через web интерфейс.
Виноват был Comodo Firewall на шлюзовой машинке.

через web интерфейс отправляется и с вложениями и без,
а через [thunderbird] с вложениями не хочет.
Outpost Firewall Pro и аваст отключал толку нет. (да и письма без вложений проходят).
Все вариации настроек портов перерыл не пашет.

у меня например такое подозрение что виновата встроенная в мать сетевая карта....
а точнее дрова на неё... иначе просто не понимаю почему на моем же компе с другой сетевухой уходят сообщения хоть прикрепленные, хоть нет....

мать     Foxconn NF4K8AB/NF4K8AC Series

[ Сетевые платы / NVIDIA nForce Networking Controller - Минипорт планировщика пакетов ]
 
        Свойства устройства:
            Описание драйвера      NVIDIA nForce Networking Controller - Минипорт планировщика пакетов
            Дата драйвера      01.07.2001
            Версия драйвера      5.1.2535.0
            Поставщик драйвера      Microsoft
            INF-файл      netpsa.inf
            Аппаратный ID      ms_pschedmp
 
    [ Сетевые платы / NVIDIA nForce Networking Controller ]
 
        Свойства устройства:
            Описание драйвера      NVIDIA nForce Networking Controller
            Дата драйвера      24.11.2004
            Версия драйвера      4.6.6.0
            Поставщик драйвера      Nvidia
            INF-файл      oem4.inf
            Аппаратный ID      ***********
            Сведения о размещении      NVNETBUS Id: 000a0000

больше у меня вариантов нету..... 
как такое возможно ...видать какая то часть птицы конфликтует с драйвером сетевухи... и какой то параметр отправки сообщения зависает на этапе авторизациии с smtp  сервером...

ilya198293 пишет:

У меня была ситуация когда на mail.ru я не мог отправить почту с прикреплёнными файлами не через smtp не через web интерфейс.Виноват был Comodo Firewall на шлюзовой машинке.

Ну что там на шлюзовой машине это тока мой провайдер знает.

14-01-2010 16:34:39

Dimorus пишет:

у меня например такое подозрение что виновата встроенная в мать сетевая карта

Проверить не имею возможности!
Работаю с ноутбука
Сетевой адаптер Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC

Thunderbird 3.0 - метод исправления

noctal пишет:

Content-Disposition: attachment; filename="file.jpg"

не помог!
Черновик у меня лежит в файле \ThunderbirdPortable\Data\profile\Mail\pop3.mail.ru\Drafts


Настроил Microsoft Office Outlook 2007 на mail.ru
Письма без вложений уходят нормально. С вложениями уходят тоже, но Outlook этого не видит и делает еще 2 попытки отправить письмо, т.о. письмо приходит по 3 раза. Outlook считает его не отправленным и в папку отправленные не перемещяет!!!

Все это говорит что проблема не в [thunderbird], а в чем то другом!!!

я вот думаю что где то не правильно фукционирует обмен между птицей и дровами на сетевуху.... какойто  параметр косячный...
только как это отследить бы....

Поставил Windows 7 и проблема исчезла!

P.S.: Обновляйте Outpost Firewall !!!!

значит кривые дрова под xp .....

Changes in Outpost Firewall  Pro 2009 (6.7.2 3001.452.0718) 15 January 2010: Следующие проблемы исправлены (приведены только основные):
.....................................................................................................................................
В почтовом клиенте Thunderbird не отправлялись вложения по протоколу SMTP
.....................................................................................................................................

Подтверждаю. Не отправлялись вложения на smtp.mail.ru и на корпоративный MDaemon. На яндекс и на gmail уходили.
Обновил Outpost  с 6.71 до 6.72 - проблема исчезла
Thunderbird - 3.0-3.01

shmutz пишет:

Подтверждаю. Не отправлялись вложения на smtp.mail.ru и на корпоративный MDaemon. На яндекс и на gmail уходили.
Обновил Outpost  с 6.71 до 6.72 - проблема исчезла
Thunderbird - 3.0-3.01

Подтверждаю, была именно такая проблема (TB не отправлял письма с вложениями, а Опера отправляла без проблем), решилась обновлением Outpost. На самом деле мне совершенно не ясна связь между исходящим трафиком TH и Outpost...

так какое решение этой проблемы?
У меня начались такие же глюки с разными серверами отправки почты, раньше все работало нормально

версия 2.0.0.24 (20100228)

Firewall  нет

Ау!!какое решение этой проблемы?

У меня  ситуация  на mail.ru удалено, не мог отправить почту с файлами не через smtp ни как иначе, Виноват был Comodo Firewall, так что можно решить.

Firewallов  нет вложения отправлять отказывается с любого почтового сервера

обновил до 3.0.4 проблема осталась - не отправляются письма с вложениями!
Что бросить этот почтовик и переходить на другой ?

Да -конечно же бросить... :) Дело за Вашим личным выбором и никто из присутствующих пользователй ТВ, я Вас уверяю, на Вас в обиде не будет.

Rosenfeld очень дельный совет по решению проблемы, спасибо, большое спасибо!
придется так и поступить

Пишу для тех кто столкнется с такой же проблемой и получит "дельный совет" типа совета от Rosenfeldа
Проблема решилась оказывается очень просто  :)
По удалял из части отправленных  ранее писем вложения, так как посмотрел  - общий размер  папки  ThunderbirdPortable уже составил 1.6Г :)
По всей видимости надо где то в настройка надо установить "удалять отправленные вложения" чтобы не чистить базы в ручную

Недавно столкнулся с такой же проблемой и нашел решение! не отправлялись письма с вложениями, причем как через почтовые программы, так и через вэб. перепробывал все: просканил на вирусы, менял пачкорд, ставил разные версии почтовиков и браузеров, переставлял дрова на мать и сетевуху, менял сетевуху, проверял настройки фаервола и все безрезультатно... в итоге помогло форматирование диска цэ и переустановка системы. при переустановке системы без форматирования проблема не решалась. вот специально зарегился на этом форуме и решил поделиться опытом, вдруг кому нибудь пригодится! спасибо за внимание:)

Отличное решение! Спасибо!

Nbor
Уважаемый у меня чуть более 2,5 Гб папка с Portable TB  и я пока не чистил ничего и все отпралялось. Только хочу уточнить у меня внешний HDD отформатированный в NTFS.
А у вас на чем хранится Portable TB.
У меня были не понятные косяки с отправкой но это просто решилось регулировкой настроек "ПАРАМЕТРЫ СЕРВЕРА" защищенный не защищенный и т.п.

Столкнулся с проблемой, Thunderbird периодически ругаете что не может отправить сообщение, бывают письма с вложениями и без. Но самое главное что на самом деле письма уходят (проверяли на почтовом сервере), но при этом Thunderbird сообщает, что не отправил письмо и в отправленные копия письма не попадает. Меняли версии Thunderbird не помогает… В чем проблема вообще не понятно.