Уже около месяца у меня периодически возникает очень неприятная ситуация, когда страницы форума не загружаются до конца.
Чаще всего это происходит с темами форума. Причём, темы из 3-5 сообщений практически всегда загружаются нормально. Более длинные темы загружаются лишь до 7-8 сообщения. С листингами тем разделов/результатов поиска аналогичная ситуация, но проявляется она гораздо реже.

Выглядит это так:
листинг тем форума
произвольная тема

Думал, что это мой баг и пытался искать причину проблемы, но выяснить так ничего и не смог...

Вчера совершено случайно на irc-канале нашего проекта в moznet выяснилось, что данная проблема проявляется не только у меня. Баг подтвердили ещё два человека.

Собственно, по этому я и создал эту тему. Очень надоело по 20 раз обновлять страницу форума, тем более, что это не всегда помогает :angry:

Есть у кого-нибудь аналогичная проблема?

Что-то похожее у меня бывает, но на других форумах. Обычно при загрузке очень больших(например версия для печати темы в которой страниц 30, а то и больше). Имхо, связано это с качеством связи или, быть может, с таймаутом соединения, прокси с ограничениями.

Аналогичная ситуация. Из-за этого почти не могу пользоваться форумом. Грешил на коннект, но форумы на mozillazine загружаются нормально.

DrLabRus
у меня такое проявляется только на данном форуме. на коннект жаловаться не могу

ego
аналогично. читать форум становится очень трудно, писать что-либо получается очень редко

Бывает и у меня. НО только в случае если я иду через проксик. Если его отключить - грузится нормально. Выходил из ситуации так - на недогруженной странице жму Ответить и как правило все недогруженные посты появляются под формой ответа :) Грешу на проксик

У меня такое было... Вылечилось тем, что в профиле указал не 75 сообщений на страницу, а 50... :)

Мб это связано с кривостью пути до сайта форума?
Можно попробовать смотреть форум через прокси (например с помощью HandyCache).

ragnaar

Выходил из ситуации так - на недогруженной странице жму Ответить и как правило все недогруженные посты появляются под формой ответа

Спасибо за совет

Modex

У меня такое было... Вылечилось тем, что в профиле указал не 75 сообщений на страницу, а 50...

Надо попробовать поставить 10, т. к. умолчальные 25 грузиться не хотят :)

мда.
указал 50 тем и 10 сообщений :/
вроде пока работает :rolleyes:

ragnaar пишет:

Бывает и у меня. НО только в случае если я иду через проксик...

Аналогично, если через прокси, то не догружаются некоторые длинные страницы в "Новостях" и "Флейме".

Подтверждаю!

Началось с 19 октября!

Причем, и в ФФ, и в ИЕ.
Перезагрузки и очистки кеша и т.п. ни к чему не приводят. Не грузятся и все тут!

Связь: диал-ап, без всякого прокси. Сама связь устойчивая.

Наблюдается не только на этом форуме. Есть еще пара форумов где именно через фокса такая беда.

У меня вот эта страница (версия для печати) грузиться до:

helicopter > 21-03-2007 20:56:08

на этом страница заканчивается :(

P.S. Proxy не использую.

stEp
Везёт тебе. У меня только до

helicopter > 21-03-2007 14:56:08

грузится.

Infant, Ааа! Ты вычислил мой часовой пояс :)
На самом то деле смешного мало... хотелось бы чтобы страницы всё же грузились полностью.

Квизац_Хадерач
в данном случае проблема в форуме. у меня проявляется во всех браузерах.

stEp
Infant
про версию для печати вообще разговор отдельный, по скольку там нельзя выбрать количество отображаемых постов. у меня, например, только до

Выделить код

Код:

igorsub > 18-03-2007 02:32:11

загрузилось :sick:

2 Администрация
вопрос будем решать как-нибудь?

у меня проявляется во всех браузерах.

Это да. Щас в Симанки открыл ту ссылку и застыло на пол странице :(

У меня вот эта страница (версия для печати)

Тоже только до:
helicopter > 21-03-2007 15:56:08

Открывается полностью
http://people.mozilla-russia.org/sergeys/images/page.png хотя это не говорит, что у всех должно работать

Вот это: http://pastebin.mozilla-russia.org/90223 сервер возвращает на самый первый GET если прокси включен и страница не догружается; вот это: http://pastebin.mozilla-russia.org/90224 - если прокси отключен и страница загружается полностью.

Ещё наблюдение: страница этой темы загружается полностью, если я не зашёл в форум, когда захожу - до конца не загружается. (при включенном в обоих случаях прокси).

Проблема та же. Прокси нет.
Если поставить 10-15 сообщений на странице, работает нормально, 20 виг вам.
Глючат кстати далеко не все темы.
Эту тему до конца смог увидеть только при 10 сообщениях на странице. :angry:
Надо бы исправить положение. А то частенько можно прочитать что другие сайты кривы, а тут собственный оказывается глючит по самое мама не балуй.

хм. под Linux у меня нормально загружается...

До:

Erik > 21-03-2007 14:35:42

SeaMonkey/1.1.5 настройки пока дефолтные.

Страницы - не версии для печати всегда нормально загружаются - до конца, правда баннеры, шапка и смайлы отрублены. Вот это всё смайлы вредят кому-то.))

У меня есть один знакомый форум, на котором вот уж 2 что ли года больше половины страниц загружаются до конца только после ререзагрузки: трели ру, но другие чёт не жалуются...

Ещё такое впечатление, что летом собрал помощнее системник и версии для печати на руборде перестали недогружаться (правда картинки бывает и недогружаются) раньше регулярно вот так же сама страница полностью не грузилась. Профиль переносил со всеми настройками даже и не знаю в чём дело - может в системе где-то что-то настроено по-разному или файрволы разные..
Sergeys

Открывается полностью

prefs.js выложи, плиз, если там нет интимного чего-нибудь.
Ещё бы, не исключено, может иметь значение у кого какая скорость подключения и за сколько секунд вся стр загружается.

vladmir

prefs.js выложи, плиз, если там нет интимного чего-нибудь.

сожалею, есть :)

ragnaar пишет:

Бывает и у меня. НО только в случае если я иду через проксик. Если его отключить - грузится нормально. Выходил из ситуации так - на недогруженной странице жму Ответить и как правило все недогруженные посты появляются под формой ответа :) Грешу на проксик

А можно нажать кнопку "версия для печати" в правом верхнем углу и тогда  вся тема отобразится, правда все сообщения будут на 1 странице и если тема большая то и страница будет огромной.... неудобно но как выход пойдет....

tashmen
Это вряд ли. Здесь http://forum.mozilla-russia.org/viewtopic.php?pid=200339#p200339 давали ссылку на такую страницу версии для печати, которая не у всех загружается полностью.

Infant
На сервере были увеличены лимиты, прошу проверить еще раз.

Больше 15 начинает работать как хочет, то открываются темы до конца, то нет :dumb:

lakostis
У меня всё то же.

helicopter > 21-03-2007 14:56:08

Прямо как будто больше не помещается в какой-то буфер. Хотя на двойке удалось чуть дальше продвинуться.

Erik > 29-03-2007 18:37:13

Новость. Тут уже как-то рассказывали, что делл решил собрать идеи о том, чего хотят пользователи. Самая популярная просьба - причем намного опередившая все остальные идеи - компьютеры и ноутбуки с предустановленным линуксом. Так вот теперь Делл отреагировал и, похоже, пойдет-таки навстречу пользователям. Но гла

lakostis пишет:

...
На сервере были увеличены лимиты, прошу проверить еще раз.

У меня без изменений.

16.52 - 24 окт. 2007 г.

Не открываются! И с рабочей машины, и с домашней!

Пример: http://forum.mozilla-russia.org/viewtopic.php?id=19291 (только 2,5 сообщения в ФФ, 3 - в ИЕ).

Rosenfeld Поставте в настройках 50 тем 10 сообщений, хоть на форум посмотрите :)

@all
На новом профиле ситуация та же?

Unghost пишет:

@all
На новом профиле ситуация та же?

На работе смотрю форум через ISA - не догружается.  Дома напрямую - все в порядке.

Дня три назад началось.

странно, но в убунту у меня загружаются все 75 сообщений из темы. хотя, версии для печати грузятся не до конца...

Rosenfeld Поставте в настройках 50 тем 10 сообщений, хоть на форум посмотрите :)

Я в это не поверил, но все же поставил даже так: 10 сообщений - 10 тем (хотя, как Вы знаете, если там поля настроек соответствующие вообще не заполнять, то форум будет отображаться "по умолчанию", т.е. именно в таком режиме, как и предполагали разработчики).

Более того - для чистоты эксперимента снес старый ФФ напрочь, поставил 2.0.0.8.

Набор расширений даже не и устанавливал для той же чистоты эксперимента...

В режимах отображения форума стоит стандартная тема, отключена графика, подписи участников и т.п. ...
И что же - даже при  схеме 10/10, вот - реальный пример:

http://forum.mozilla-russia.org/viewtopic.php?id=121&p=5 - куцые 2 сообщения

(я думаю, даже не стоит особо упоминать, что на других форумах - примеры специально не привожу = о-огромнейшие темы открываются нормально)... Так что очень жалко - не имею возможности дочитать до конца интересные для меня сообщения!

Rosenfeld
Действительно   :mad: по ссылке какие-то обрезки.
Значит все гораздо хуже

Админы! ну сделайте что-нибудь. Или форум только для пользователей *nix'ов и ФФ v3 :whiteflag:

IgorA
А с чего ты взял что на тройке всё отлично?

Infant
Вроде с троечников :) никто не жаловался.

Хм.. 3, 4 посты с 3ой, у Modex вылечилось

Infant
Лично у меня в 3.0 всё нормально, но...
Нужно искать причину, форум должен отображаться весь и у всех!

IgorA
Ну вот у меня что в двойке, что в тройке не всё показывает. Так что я не думаю, что это именно браузер. Скорее где-то по пути что-то происходит.
Надо ещё информацию насобирать. Возможно имеет значение наличие/отсутствие реального АйПи. У меня например нету. Подключаюсь через ВПН.

Причём тут лиса вообще?
Вы в других браузерах открывали?

shutnik
Нету у нас других :)

P.S. В ИЕ то же.

Раз есть проблема, то её нужно решать. Чем мы сейчас и занимаемся.

Infant
ADSL роутер у него IP динамический, реальный. На компе естественно после NAT 192.168... но ИМХО это все не из той оперы.
Настройки форума 50/10

Кстати сейчас приведенные Rosenfeld на 4 страницы примеры отображаются нормально , что-то подкрутили или повлияли звезды и переход на зимние время :D

В качестве комментария...

У меня все отображается нормально в ИЕ, 2.0 и 3.0 :P

Не загружается до конца...но мне не влом 3-4 раза обновить страниц, чтобы получить нормый результат.

Vednier
ТоварищЪ, лОм не помогает :)
Тут несколько о другом случае речь идет.

1)
SeaMonkey 1.1.5
ego > 21-03-2007 13:17:38
2)
SeaMonkey 1.1.5
Erik > 21-03-2007 14:35:42
3)
Firefox 3.0a8
helicopter > 21-03-2007 15:56:08
4)
Netscape 9.0
helicopter > 21-03-2007 15:56:08
5)
IE 6.0
helicopter > 21-03-2007 15:56:08

диалап 50 кбит

А увеличение времени ожидания не делали?
about:config accessibility.typeaheadfind.timeout

Я поставил 10000 и все гуд

Roll_
Это таймаут для панели быстрого поиска. К загрузке страниц не имеет никакого отношения

ego
А где тайм аут ожидания на загрузку?
Сорри,что вопрос не по теме,смотрю ты пользуешься фф 3,не знаешь как убрать кнопку "добавить в закладки"?

У меня из дома форум не открывается ни в ФФ ни в ИЕ ни в Опере :(
С работы открывается любым браузером
Эти  проблемы начались где-то месяц назад.

Пару дней назад было, при работе через акселератор SpectrumSat. По земле всё нормально.

через прокси. недогруз почти всегда. :(:whiteflag: