Полезная информация

Пользователи не любят читать документацию. Станьте оригинальным, будьте не как все. Ознакомьтесь с нашей базой знаний.

Скрипты » Greasemonkey » 21-01-2013 04:06:31

Картина маслом: пробую забить парочку значений от балды с помощью скрипта, в about:config они появляются, но в pref.js всё ещё стоят абсолютно другие значения! (Закрытие/открытие браузера ничего не меняет!!)

И самое интересное, что проблема в конце концов решилась заменой файла pref.js на файл, принесённый с другого компа.

Получается, часть значений Мозилла брала из pref.js,  часть ещё откуда-то?? но после замены файла опять все значения стала брать из него, как и полагается...  Вот что это был за глюк, просто интересно уже...

Скрипты » Greasemonkey » 19-01-2013 16:00:09

Ну как бы есть разница, скопировать одним куском, или долго и уныло копипастить несколько десятков строчек, следя, чтобы в нужные переменные значения вставлять...
и хочется разобраться всё-таки, в чём проблема, и почему возникла только с переменными одного из нескольких скриптов

Скрипты » Greasemonkey » 19-01-2013 15:50:13

Хотя нет, оказывается, не всё встало :(  У одного из скриптов настройки так и не работают, в about:config имена их появились, а значения пустые, хотя в prefs.js и имена и значения заданы. Что за ерунда? :(

Скрипты » Greasemonkey » 19-01-2013 12:02:44

Kamui пишет:

Обычно в about:config хранятся

Kamui, спасибо, нашёл )

потом посмотрел место физического хранения... кроме файла prefs.js   обнаружились ещё файлы prefs-1.js, prefs-2.js, prefs-3.js, prefs-4.js...
вот в последнем из них и обнаружились затёршиеся настройки. скопировал нужный кусок файла, всё встало

Непонятно только, почему Мозилла сама не предлагала возможность восстановления, если уж произошёл сбой :(

Скрипты » Greasemonkey » 19-01-2013 08:56:19

Посмотрел, в config.xml нужных настроек нет, видимо скрипты GM сохраняют их в своих переменных, когда позволяет на определённых страницах создавать и запоминать наборы данных. Где ещё посмотреть можно?

Скрипты » Greasemonkey » 16-01-2013 21:41:24

При перезагрузке компа слетели все настройки скриптов GM (хотя сами скрипты работают). Есть бэкап папки с Мозилловским профилем , также некоторое время назад экспортировал профиль со всеми скриптами и настройками на другой комп. Но полностью профиль не хочется ниоткуда восстанавливать, другие последние изменения могут убиться... Как бы настройки только восстановить? Где они физически хранятся?

Скрипты » Greasemonkey » 01-06-2012 20:42:52

спасибо, помогло вроде

Скрипты » Greasemonkey » 01-06-2012 19:31:26

Помогите, плиз, в GM слетели все скрипты (тупо не видит их)

Такое уже было один раз на другом компе, тогда помогло отключение/включение GM с перезагрузкой браузера
Сейчас ничего не помогает

Скриптов с настройками очень много, заново качать и настраивать это убиться можно.
Как исправить?

Архив тем » не работает javascript для конкретного сайта » 03-03-2012 17:44:08

zit пишет:

а конкретнее?

В смысле?
Глючат отображение и функции форума, а на месте кнопки отправки сообщений форум  так и выдаёт, что включить javasript надо

Архив тем » не работает javascript для конкретного сайта » 03-03-2012 14:38:11

Перестал работать javascript на форуме рутрекера :( хотя на днях ещё всё было нормально. Никаких новых расширений не устанавливал, вообще вроде не менял ничего. В Опере всё работает, а в Мозилле нет. Опция "Использовать Javascript" включена. С Shift+F4   javascript:alert выполняется.
Firefox 10.0.2

Firefox » Не открываются веб-страницы с расширением .php » 20-07-2011 18:50:26

чудеса!

1) Проблема была всё-таки с конкретным ресурсом, проверил на ещё одном форуме, там "index.php" открывался
2) в безопасном режиме проблема осталась
3) под новым профиле проблема пропала, более того, и на моём дефолтном сейчас исчезла! :)

Wartys пишет:

Мои наблюдения показывают, что проблема связана с некачественным Internet-соединением или его сбоем

Да, очень возможно, были проблемы с трассировкой этого сайта, почему и под прокси пробовал.

Wartys пишет:

Пробуйте кэш скинуть или вовсе переустановить

хм, опять же, возможно, действительно чистка кэша помогла, хотя мне казалось, я её чуть раньше попробовал...

Firefox » Не открываются веб-страницы с расширением .php » 20-07-2011 08:25:28

hydrolizer пишет:

Абсолютно все php-страницы себя так ведут?

Страницы игрового ресурса, у которых URL заканчивается именно на '.php' Форум этого же ресурса грузится нормально, хотя и там наверняка php-движок. Как приду домой, могу потестировать ещё, поищу странички других сайтов, оканчивающиеся на .php...

mcfly пишет:

Ссылку дайте, что у вас там не открывается

странички с heroeswm.ru , но там регистрация нужна.

hydrolizer пишет:

Сдается мне, что это проблема отдельного сайта - он неправильно отдает MIME-type своих страниц

Вряд ли, отдавал-отдавал, и вдруг в какой-то момент стал отдавать неправильно?  Ощущение, что дело всё-таки в где-то в моих настройках, ибо ошибка появилась как раз в тот момент, когда я перебирал прокси.

Firefox » Не открываются веб-страницы с расширением .php » 20-07-2011 04:39:58

Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
Выдаёт окошко
"Вы собираетесь открыть файл
являющийся  application/octet-stream"

Проблема началась при работе под прокси, может, дело как-то связано с этим?
Однако сейчас в настройках стоит "Без прокси", перегружал браузер, перегружал Windows, проблема осталась
В Опере всё открывается нормально.

Поддержка пользователей » Загрузка ЦП 3-ей Лисой! » 22-09-2009 08:03:46

Ну установил флэшблок... немногим лучше. Флэш всё также грузит проц, только теперь, чтобы видеть его, приходится ещё и кликать дополнительно.

Поддержка пользователей » Загрузка ЦП 3-ей Лисой! » 21-09-2009 08:49:18

>> ставим начисто винду
а не радикальненько ли?

>> анитивирус с файрволом
как я уже тут писал http://forum.mozilla-russia.org/viewtop … 01&p=2 вирусы ни при чём, стоит обновляемый Касперский, недавно как раз по другой причине очень серьёзно проверял комп несколькими антивирусами и утилитами(всё чисто)

На эту проблему с тормозами из-за флэш-плагина уже давно многие жалуются, но до сих пор я так и не нашёл нигде ответа...

зачем вы предлагаете "адблок с ноускриптом"? Проблема состоит в загрузке проца ЛЮБОЙ страницей с флэшем. В общем-то  и избавиться от тормозов очень просто - тупо отключить Flash-плагин. Но тогда и любой полезный Flash-контент тоже будет недоступен (как, например, с браузерной флэш-игрой быть?)

Поддержка пользователей » Firefox 3 грузит процессор на 100% » 12-09-2009 09:16:54

diablist пишет:

но без флеша как-то не везде возможно ((

особенно в браузерной флэш-игре ;)

Знать бы, с чем у плагина конфликт...

Поддержка пользователей » Firefox 3 грузит процессор на 100% » 11-09-2009 11:27:06

Хм, обновил, до 3.5.3, всё равно та же картина. Что ж это за пакостный глюк?

Поддержка пользователей » Firefox 3 грузит процессор на 100% » 29-08-2009 12:03:22

WinXP. С некоторого времени некоторые сайты в Firefox стали моментально загружать процессор на 100%, через некоторое время тотальное зависание системы и/или падение браузера.

Обновился с 3.0.13 до 3.5.2. Не помогло.

Отключил уже все установленные мной расширения (вдруг какое из них виновато?). Не помогло.

(в Опере и IE все страницы открываются нормально без сильного загруза).

Уже потом понял, что дело во флэше (глюки именно со страницами, содержащими flash). Отключил Shockwave Flash 10.0.32.18 во вкладке "Плагины" (я как-то не замечал раньше нужной вкладки, и даже что мозилла уже установленный по умолчанию плагин со своим флэшем юзает, не знал...) Подействовало - причина нашлась.

Узнал, что не у одного меня этот глюк. Гугление не помогло решить этот вопрос. Поиск по этому форуму тоже не дал ответа, из-за чего глюк с флэшем происходит, и как его пофиксить  Пожалуйста, если кто знает, дайте ответ или пруфлинк

Поддержка пользователей » Тормоза из-за Flash-плагина » 28-08-2009 17:58:56

WinXP. С некоторого времени некоторые сайты в Firefox стали моментально загружать процессор на 100%, через некоторое время тотальное зависание системы и/или падение браузера.

Обновился с 3.0.13 до 3.5.2. Не помогло.

Отключил уже все установленные мной расширения (вдруг какое из них виновато?). Не помогло.

(в Опере и IE все страницы открываются нормально без сильного загруза).

Уже потом понял, что дело во флэше (глюки именно со страницами, содержащими flash). Отключил Shockwave Flash 10.0.32.18 во вкладке "Плагины" (я как-то не замечал раньше нужной вкладки, и даже что мозилла уже установленный по умолчанию плагин со своим флэшем юзает, не знал...) Подействовало - причина нашлась.

Узнал, что не у одного меня этот глюк. Гугление не помогло решить этот вопрос. Поиск по этому форуму тоже не дал ответа, из-за чего глюк с флэшем происходит, и как его пофиксить :( Пожалуйста, если кто знает, дайте ответ или пруфлинк

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]