Полезная информация

Заказывай стафф с атрибутикой Mozilla и... пусть все вокруг завидуют тебе! Быть уникальным - быть с Mozilla!

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 25-01-2017 17:44:34

Победил-таки.
К сожалению точно сказать не могу сейчас причину. Сразу много настроек сбросил. Но после заработало.
Плюс, сразу не обратил внимание, что у меня включена синхронизация настроек между рабочим и домашним лисом. Склоняюсь теперь к мысли, что в этом и бал причина.
В общем, первое что сделал отключил синхронизацию настроек.
Затем в about:config открыл все параметры с состоянием "Установлено пользователем" и просто стал тупо сбрасывать все настройки, которые своим наименованием хотя бы отдалённо могли быть причастны к мультимедиа и видео.
Сбросил больше десятка, перезапустился и всё заработало.
Почему-то подозрение на два параметра: media.wmf.disable-d3d9-for-dlls и media.wmf.disable-d3d11-for-dlls.
Сейчас они имеют значения по умолчанию, а раньше в них много всяких библиотечек было прописано. Если эти параметры блокируют работу некоторых dll из набора DirectX, то может быть там действительно были лишние файлы указаны и поэтому видео не шло. Правда это может быть верно только

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 20-01-2017 17:32:32

banbot пишет:

Maesterus
А если запустить [firefox] в безопасном режиме?

О, это я всё испробовал. И безопасные режимы, и новые профили и чистую установку.
Один раз новый профиль помог. В нём видео отображалось, а в старом нет.
Решил, что всё исправил и не додумался сохранить конфиги, что бы потом сравнить. А через день всё вернулось на круги своя.

Шайтан, однако

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 17-01-2017 19:03:36

banbot пишет:

Maesterus
Ну и как теперь выглядит about:support?

скрытый текст
https://dl.dropboxusercontent.com/u/930816/ff/ss-fullpage.png

Когда я включал layers.prefer-d3d9, то выглядело так

скрытый текст
https://dl.dropboxusercontent.com/u/930816/ff/d9-fullpage.png

layers.d3d11.force-warp так же не помог

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 15-01-2017 15:50:20

barth пишет:

Драйвера в черном списке)
Пробуй:
media.hardware-video-decoding.force-enabled = true
media.hardware-video-decoding.failed = false
media.wmf.skip-blacklist = true
media.wmf.disable-d3d11-for-dlls = очисти всё
media.wmf.disable-d3d9-for-dlls = очисти всё
Должно:  Аппаратное декодирование H264    Yes; Using D3D11 API

Всё сделал, аппаратное декодирование Yes; Using D3D11 API
Не помогло

15-01-2017 15:53:05

banbot пишет:

Maesterus
Скорее всего аппаратное ускорение в этой версии [firefox] несколько раз упало, после чего [firefox] его автоматически отключил.
В дополнение к советам barth также очисть все настройки начинающиеся на gfx.crash-guard..
Также можно попробовать установить параметр layers.prefer-d3d9 в true.
Ну и попробовать другую версию драйверов Nvidia, если ничто не поможет.

14-01-2017 21:19:49
Ещё можно установить параметр layers.d3d11.force-warp в true, но это [url=https://en.wikipedia.org/wiki/Windows_Advanced_Ra

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 13-01-2017 17:43:33

barth пишет:

"media.hardware-video-decoding.force-enabled", false
"media.hardware-video-decoding.failed", false

Не помогает

13-01-2017 17:50:20

banbot пишет:

Maesterus
Приведите данные со страницы about:support в [firefox]

Скрин:

скрытый текст
https://dl.dropboxusercontent.com/u/930816/ff/support-fullpage.png

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 05-01-2017 11:12:26

Системные кодеки я проверил сразу же. Все версии актуальные и идентичные с теми версиями Windows где проблем с FF нет.
Chrome, Vivaldi и Edge работают без проблем.
Тестовое видео которое работает везде: http://www.w3schools.com/html/html5_video.asp
Я плагин h264 сносил и заставлял Лиса тянуть его заново. Не помогает.
В моей системе только Firefox отказывается работать с видео mp4.
Как то получилось заставить его проработать пару дней без проблем, когда подменил ему библиотеку gmpopenh264.dll
Поставил от 32-битной версии FF и в настройках изменил media.gmp-gmpopenh264.abi на x86-msvc-x64
Заработало видео, хотя было написано, что видеокодек OpenH264 будет загружен позже.
Через два дня всё опять перестало работать. И теперь подобное не прокатывает.

Поддержка пользователей » Перестало работать видео MP4 и GIFV » 03-01-2017 18:04:05

Приветствую и всех с прошедшим Новым Годом!

Поломалось в любимом Лисе воспроизведение MP4 видео и GIFV.
Бьюсь уже вторую неделю, ничего не помогает. Сравниваю все известные мне настройки с другим компьютером, на котором та же самая версия FF - всё один в один. Плагины имеются и активны.
Поставил Firefox с нуля, сделал новый профиль. Несколько дней видео отображалось, потом опять поломалось. И это при том, что никаких расширений не ставил кроме тех, что установил изначально и которые установлены ещё на двух машинках, на которых проблем нет и никогда не было.
Отключение расширений то же эффекта не даёт.
С параллельно установленными хромом и вивальди проблем нет. Проблемы были как на x86 версии, так и на свежей x64.
Настройки переключал по разному. Установлен Windows 10 x64, но всё-равно добавил параметр media.gmp-eme-adobe.forceSupported. Всё бестолку.

Вот что имею:
[spoiler]https://dl.dropboxusercontent.com/u/930816/ff/Screenshot%20001.png
[img]https://dl.dropboxuserconten

Board footer

Powered by PunBB
Modified by Mozilla Russia
Copyright © 2004–2011 Mozilla Russia
Язык отображения форума: [Русский] [English]